# Logstash setting LS\_JAVA\_HOME

**URL:** https://discuss.elastic.co/t/logstash-setting-ls-java-home/307538
**Category:** Logstash
**Created:** [June 17, 2022, 7:05pm UTC](https://discuss.elastic.co/t/logstash-setting-ls-java-home/307538 "2022-06-17T19:05:29Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![BRosenberg](https://avatars.discourse-cdn.com/v4/letter/b/df705f/32.png) [@BRosenberg](https://discuss.elastic.co/u/BRosenberg)
#### Post date: [June 17, 2022, 8:51pm UTC](https://discuss.elastic.co/t/logstash-setting-ls-java-home/307538/5 "2022-06-17T20:51:14Z")

</div>

> [@Badger](#):
>
> You would set it in the shell that calls logstash. Are you running it as a service?

Ah ok. Yes, I'm running it as a service via `systemctl start logstash.service`

I added `LS_HOME_JAVA="/usr/bin/java"` to `/etc/defaults/logstash` that gets logstash to use `LS_JAVA_HOME` but it still doesn't start.

```auto
Jun 17 21:10:11 elk systemd[1]: Started logstash.
Jun 17 21:10:11 elk logstash[14699]: Using LS_JAVA_HOME defined java: /usr/bin/java.
Jun 17 21:10:11 elk logstash[14699]: Invalid LS_JAVA_HOME, doesn't contain bin/java executable.
Jun 17 21:10:11 elk logstash[14699]: Could not find java; set LS_JAVA_HOME or ensure java is in PATH.
Jun 17 21:10:11 elk systemd[1]: logstash.service: Main process exited, code=exited, status=1/FAILURE
Jun 17 21:10:11 elk systemd[1]: logstash.service: Failed with result 'exit-code'.
Jun 17 21:10:11 elk systemd[1]: logstash.service: Scheduled restart job, restart counter is at 2.
Jun 17 21:10:11 elk systemd[1]: Stopped logstash.

```

---

_[View the full topic](https://discuss.elastic.co/t/logstash-setting-ls-java-home/307538)._
