# Logstash startup error-) Could not load FFI Provider: (NotImplementedError) FFI not available

**URL:** https://discuss.elastic.co/t/logstash-startup-error-could-not-load-ffi-provider-notimplementederror-ffi-not-available/330904
**Category:** Logstash
**Created:** [April 27, 2023, 6:19am UTC](https://discuss.elastic.co/t/logstash-startup-error-could-not-load-ffi-provider-notimplementederror-ffi-not-available/330904 "2023-04-27T06:19:17Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![karthic](https://avatars.discourse-cdn.com/v4/letter/k/f4b2a3/32.png) [@karthic](https://discuss.elastic.co/u/karthic)
#### Post date: [April 27, 2023, 6:19am UTC](https://discuss.elastic.co/t/logstash-startup-error-could-not-load-ffi-provider-notimplementederror-ffi-not-available/330904/1 "2023-04-27T06:19:17Z")

</div>

Tried to load logstash in a Centos environment

[INFO][logstash.runner] JVM bootstrap flags: [-Xms1g, -Xmx1g, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -Djruby.regexp.interruptible=true, -Djdk.io.File.enableADS=true, --add-exports=jdk.compiler/com.sun.tools.javac.api=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.parser=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.tree=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.util=ALL-UNNAMED, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]  
[2023-04-28T11:16:46,268][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (LoadError) Could not load FFI Provider: (NotImplementedError) FFI not available: null  
See [http://jira.codehaus.org/browse/JRUBY-4583](http://jira.codehaus.org/browse/JRUBY-4583)  
org.jruby.exceptions.LoadError: (LoadError) Could not load FFI Provider: (NotImplementedError) FFI not available: null  
See [http://jira.codehaus.org/browse/JRUBY-4583](http://jira.codehaus.org/browse/JRUBY-4583)  
at org.jruby.ext.jruby.JRubyUtilLibrary.load\_ext(org/jruby/ext/jruby/JRubyUtilLibrary.java:216) ~[jruby.jar:?]  
at RUBY.(/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/ffi-1.15.5-java/lib/ffi.rb:11) ~[?:?]  
at org.jruby.RubyKernel.require(org/jruby/RubyKernel.java:1017) ~[jruby.jar:?]  
at RUBY.module:LibC(/usr/share/logstash/logstash-core/lib/logstash/util/prctl.rb:19) ~[?:?]  
at RUBY.(/usr/share/logstash/logstash-core/lib/logstash/util/prctl.rb:18) ~[?:?]  
at org.jruby.RubyKernel.require(org/jruby/RubyKernel.java:1017) ~[jruby.jar:?]  
at RUBY.set\_thread\_name(/usr/share/logstash/logstash-core/lib/logstash/util.rb:36) ~[?:?]  
at RUBY.execute(/usr/share/logstash/logstash-core/lib/logstash/runner.rb:365) ~[?:?]  
at RUBY.run(/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:68) ~[?:?]  
at RUBY.run(/usr/share/logstash/logstash-core/lib/logstash/runner.rb:287) ~[?:?]  
at RUBY.run(/usr/share/logstash/vendor/bundle/jruby/2.6.0/gems/clamp-1.0.1/lib/clamp/command.rb:133) ~[?:?]  
at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:90) ~[?:?]  
Caused by: org.jruby.exceptions.NotImplementedError: (NotImplementedError) FFI not available: null

Unable to start the logstash. Please instruct me step by step to resolve it

My config as follows  
input {  
beats {  
port =\> 5044  
}  
}

output {  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"  
}  
}

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [April 27, 2023, 2:40pm UTC](https://discuss.elastic.co/t/logstash-startup-error-could-not-load-ffi-provider-notimplementederror-ffi-not-available/330904/2 "2023-04-27T14:40:32Z")

</div>

Please do not use images of text, just post the text. Images are not searchable and some folk may not be able to see them at all.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 25, 2023, 2:40pm UTC](https://discuss.elastic.co/t/logstash-startup-error-could-not-load-ffi-provider-notimplementederror-ffi-not-available/330904/3 "2023-05-25T14:40:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
