# Logstash startup error in docker container

**URL:** <https://discuss.elastic.co/t/logstash-startup-error-in-docker-container/220479>\
**Category:** Logstash\
**Created:** [February 22, 2020, 10:27am UTC](https://discuss.elastic.co/t/logstash-startup-error-in-docker-container/220479 "2020-02-22T10:27:22Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![sahar](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@sahar](https://discuss.elastic.co/u/sahar)\
**Post date:** [February 22, 2020, 10:27am UTC](https://discuss.elastic.co/t/logstash-startup-error-in-docker-container/220479/1 "2020-02-22T10:27:22Z")

</div>

Hello,  
I'm trying to run ELK for the first time inside a docker-container using the image sebp/elk and it seems to be failing to start with a clean installation on logstash in particular.

These are the startup logs:  
elk | ==\> /var/log/logstash/logstash-plain.log \<==  
elk | [2020-02-22T10:04:10,425][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.6.0"}  
elk | [2020-02-22T10:04:12,709][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of [\t\r\n], "#", "input", "filter", "output" at line 1, column 1 (byte 1)", :backtrace=\>["/opt/logstash/logstash-core/lib/logstash/compiler.rb:47:in `compile_imperative'", "/opt/logstash/logstash-core/lib/logstash/compiler.rb:55:in `compile\_graph'", "/opt/logstash/logstash-core/lib/logstash/compiler.rb:17:in `block in compile_sources'", "org/jruby/RubyArray.java:2580:in `map'", "/opt/logstash/logstash-core/lib/logstash/compiler.rb:14:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:161:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:47:in `initialize'", "/opt/logstash/logstash-core/lib/logstash/java_pipeline.rb:27:in `initialize'", "/opt/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:36:in `execute'", "/opt/logstash/logstash-core/lib/logstash/agent.rb:326:in `block in converge\_state'"]}  
elk | [2020-02-22T10:04:12,987][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
elk | [2020-02-22T10:04:18,045][INFO][logstash.runner] Logstash shut down.

Any idea what am I missing?

---

<div class="post-metadata">

**Author:** ![sahar](https://avatars.discourse-cdn.com/v4/letter/s/ea5d25/32.png) [@sahar](https://discuss.elastic.co/u/sahar)\
**Post date:** [February 22, 2020, 2:40pm UTC](https://discuss.elastic.co/t/logstash-startup-error-in-docker-container/220479/2 "2020-02-22T14:40:06Z")

</div>

Solved my own problem, for anyone interested it was because the configuration file was saved as UTF-8 with BOM

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 21, 2020, 2:42pm UTC](https://discuss.elastic.co/t/logstash-startup-error-in-docker-container/220479/3 "2020-03-21T14:42:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
