# Logstash Stuck Indexing Pipeline and throwing Error - warning: already initialized constant Manticore::Client::HttpPost

**URL:** https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948
**Category:** Logstash
**Created:** [October 27, 2023, 6:49pm UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948 "2023-10-27T18:49:14Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![mnasim1](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@mnasim1](https://discuss.elastic.co/u/mnasim1)
#### Post date: [October 27, 2023, 6:49pm UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/1 "2023-10-27T18:49:15Z")

</div>

Logstash was running fine and successfully reading data from the Postgres Database for indexing. However, it suddenly started throwing the following errors, causing the indexing pipeline to become stuck:

1. logstash-8.6.2/vendor/bundle/jruby/2.6.0/gems/manticore-0.9.1-java/lib/manticore/client.rb:284: warning: already initialized constant Manticore::Client::HttpPost
2. logstash-8.6.2/vendor/bundle/jruby/2.6.0/gems/manticore-0.9.1-java/lib/manticore/client.rb:536: warning: already initialized constant Manticore::Client::StringEntity

Please suggest the solution ....its urgent !!!!

Regards,  
Nasim

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [October 27, 2023, 7:10pm UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/2 "2023-10-27T19:10:48Z")

</div>

Hello and welcome,

> [@mnasim1](#):
>
> However, it suddenly started throwing the following errors

Please share the entire error log, just part of is not enough to troubleshoot it.

> [@mnasim1](#):
>
> Please suggest the solution ....its urgent !!!!

Keep in mind that there is no SLA on this forum, people will try to help when they can.

---

<div class="post-metadata">

### Author: ![mnasim1](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@mnasim1](https://discuss.elastic.co/u/mnasim1)
#### Post date: [October 28, 2023, 9:37am UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/3 "2023-10-28T09:37:45Z")

</div>

Thanks for addressing the issue!

Below is the complete log that I Logstash showing when running through window Command Line- CMD:

E:\elk\_cluster\logstash-8.6.2\bin\>logstash -f E:\elk\_cluster\logstash-8.6.2\bin\autosuggest\_index\_baseline.conf  
"Using bundled JDK: E:\elk\_cluster\logstash-8.6.2\jdk\bin\java.exe"  
Sending Logstash logs to E:/elk\_cluster/logstash-8.6.2/logs which is now configured via log4j2.properties  
[2023-10-27T20:29:20,658][INFO][logstash.runner] Log4j configuration path used is: E:\elk\_cluster\logstash-8.6.2\config\log4j2.properties  
[2023-10-27T20:29:20,658][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"8.6.2", "jruby.version"=\>"jruby 9.3.10.0 (2.6.8) 2023-02-01 107b2e6697 OpenJDK 64-Bit Server VM 17.0.6+10 on 17.0.6+10 +indy +jit [x86\_64-mswin32]"}  
[2023-10-27T20:29:20,658][INFO][logstash.runner] JVM bootstrap flags: [-Xms8g, -Xmx8g, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -Djruby.regexp.interruptible=true, -Djdk.io.File.enableADS=true, --add-exports=jdk.compiler/com.sun.tools.javac.api=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.file=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.parser=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.tree=ALL-UNNAMED, --add-exports=jdk.compiler/com.sun.tools.javac.util=ALL-UNNAMED, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED, -agentpath:C:/PROGRA~1/DYNATR~1/oneagent/agent/bin/126717~1.202/WINDOW~2/oneagentloader.dll=loglevelcon=none,datastorage=C:\ProgramData\dynatrace\oneagent\datastorage,logdir=C:/ProgramData/dynatrace/oneagent/log]  
[2023-10-27T20:29:20,725][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2023-10-27T20:29:22,323][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600, :ssl\_enabled=\>false}  
[2023-10-27T20:29:22,592][INFO][org.reflections.Reflections] Reflections took 172 ms to scan 1 urls, producing 127 keys and 444 values  
[2023-10-27T20:29:26,169][INFO][logstash.javapipeline] Pipeline `main` is configured with `pipeline.ecs_compatibility: v8` setting. All plugins in this pipeline will default to `ecs_compatibility => v8` unless explicitly configured otherwise.  
[2023-10-27T20:29:26,185][INFO][logstash.outputs.elasticsearch][main] New Elasticsearch output {:class=\>"LogStash::Outputs::Elasticsearch", :hosts=\>["localhost..."]} - alter this due to link upload issue  
[2023-10-27T20:29:26,417][INFO][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[localhost...]}} - alter this due to link upload issue  
[2023-10-27T20:29:26,801][WARN][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=\>"localhost..."} - alter this due to link upload issue  
[2023-10-27T20:29:26,828][INFO][logstash.outputs.elasticsearch][main] Elasticsearch version determined (8.6.2) {:es\_version=\>8}  
[2023-10-27T20:29:26,829][WARN][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>8}  
[2023-10-27T20:29:26,851][INFO][logstash.outputs.elasticsearch][main] Not eligible for data streams because config contains one or more settings that are not compatible with data streams: {"index"=\>"intouch\_autosuggest\_index"}  
[2023-10-27T20:29:26,854][INFO][logstash.outputs.elasticsearch][main] Data streams auto configuration (`data_stream => auto` or unset) resolved to `false`  
[2023-10-27T20:29:26,860][WARN][logstash.outputs.elasticsearch][main] Elasticsearch Output configured with `ecs_compatibility => v8`, which resolved to an UNRELEASED preview of version 8.0.0 of the Elastic Common Schema. Once ECS v8 and an updated release of this plugin are publicly available, you will need to update this plugin to resolve this warning.  
[2023-10-27T20:29:26,886][INFO][logstash.javapipeline][main] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>4, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50, "pipeline.max\_inflight"=\>500, "pipeline.sources"=\>["E:/elk\_cluster/logstash-8.6.2/bin/autosuggest\_index\_baseline.conf"], :thread=\>"#\<Thread:0x35e7ea0a@E:/elk\_cluster/logstash-8.6.2/logstash-core/lib/logstash/java\_pipeline.rb:131 run\>"}  
[2023-10-27T20:29:26,884][INFO][logstash.outputs.elasticsearch][main] Using a default mapping template {:es\_version=\>8, :ecs\_compatibility=\>:v8}  
[2023-10-27T20:29:28,073][INFO][logstash.javapipeline][main] Pipeline Java execution initialization time {"seconds"=\>1.17}  
[2023-10-27T20:29:28,863][INFO][logstash.inputs.jdbc][main] ECS compatibility is enabled but `target` option was not specified. This may cause fields to be set at the top-level of the event where they are likely to clash with the Elastic Common Schema. It is recommended to set the `target` option to avoid potential schema conflicts (if your data is ECS compliant or non-conflicting, feel free to ignore this message)  
[2023-10-27T20:29:28,867][INFO][logstash.javapipeline][main] Pipeline started {"pipeline.id"=\>"main"}  
[2023-10-27T20:29:28,905][INFO][logstash.agent] Pipelines running {:count=\>1, :running\_pipelines=\>[:main], :non\_running\_pipelines=\>}  
[2023-10-27T20:29:29,648][INFO][logstash.inputs.jdbc][main][14463c38da12782ddab979d1aadc13a973fc961054f67598f207c7e69230342c] (0.774781s) SELECT autosuggestid,userid,ldapalias,email, COALESCE(NULLIF(TRIM(firstname || ' ' || lastname), ''), ldapalias) AS fullname, status as userstatus FROM intouchsys2.slb\_autosuggest LIMIT 999999999998  
E:/elk\_cluster/logstash-8.6.2/vendor/bundle/jruby/2.6.0/gems/manticore-0.9.1-java/lib/manticore/client.rb:284: warning: already initialized constant Manticore::Client::HttpPost  
E:/elk\_cluster/logstash-8.6.2/vendor/bundle/jruby/2.6.0/gems/manticore-0.9.1-java/lib/manticore/client.rb:284: warning: already initialized constant Manticore::Client::HttpPost  
[2023-10-27T20:29:59,319][INFO][logstash.javapipeline][main] Pipeline terminated {"pipeline.id"=\>"main"}  
[2023-10-27T20:29:59,791][INFO][logstash.pipelinesregistry] Removed pipeline from registry successfully {:pipeline\_id=\>:main}  
[2023-10-27T20:29:59,791][INFO][logstash.runner] Logstash shut down.

E:\elk\_cluster\logstash-8.6.2\bin\>

Regards,  
Nasim

---

<div class="post-metadata">

### Author: ![PodarcisMuralis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/podarcismuralis/32/122606_2.png) [@PodarcisMuralis](https://discuss.elastic.co/u/PodarcisMuralis)
#### Post date: [October 28, 2023, 2:23pm UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/4 "2023-10-28T14:23:03Z")

</div>

I have exactly the same warning. I could not solve it but it started when I upgraded logstash from 7.17.7 to 8.5.3 and created another "data" folder (data2) to run 2 logstash instances simultaneously.

---

<div class="post-metadata">

### Author: ![mnasim1](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@mnasim1](https://discuss.elastic.co/u/mnasim1)
#### Post date: [October 28, 2023, 9:01pm UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/5 "2023-10-28T21:01:46Z")

</div>

Thanks for sharing the observation!

It is Logstash8.6.2, and there have been no recent upgrades. It was working fine for the past few months until last night. The system is a Google Cloud Platform (GCP) Virtual Machine (VM), but it's unclear whether there could be any impacts from GCP infrastructure.

The strange thing is that at the same time, the Quality Assurance (QA) environment is also experiencing the same issue, even though it had been running seamlessly alongside the Production (PROD) environment.

Regards,  
Nasim

---

<div class="post-metadata">

### Author: ![mnasim1](https://avatars.discourse-cdn.com/v4/letter/m/ac8455/32.png) [@mnasim1](https://discuss.elastic.co/u/mnasim1)
#### Post date: [November 3, 2023, 5:52am UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/6 "2023-11-03T05:52:57Z")

</div>

The issue still persists, but the positive aspect is that I can now ingest data successfully by refreshing the entire ELK cluster.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 1, 2023, 5:53am UTC](https://discuss.elastic.co/t/logstash-stuck-indexing-pipeline-and-throwing-error-warning-already-initialized-constant-manticore-httppost/345948/7 "2023-12-01T05:53:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
