# Logstash stuck on "Will Retry with exponential backoff"

**URL:** <https://discuss.elastic.co/t/logstash-stuck-on-will-retry-with-exponential-backoff/220221>\
**Category:** Logstash\
**Created:** [February 20, 2020, 3:52pm UTC](https://discuss.elastic.co/t/logstash-stuck-on-will-retry-with-exponential-backoff/220221 "2020-02-20T15:52:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![TDV](https://avatars.discourse-cdn.com/v4/letter/t/f475e1/32.png) [@TDV](https://discuss.elastic.co/u/TDV)\
**Post date:** [February 20, 2020, 3:52pm UTC](https://discuss.elastic.co/t/logstash-stuck-on-will-retry-with-exponential-backoff/220221/1 "2020-02-20T15:52:47Z")

</div>

Hi,

We use ELK 7.5.1 version  
It seems that logstash stucks on trying to make bulk requests to elastic when document size exceeded http.max\_content\_length:  
`[ERROR][logstash.outputs.elasticsearch][index_name] Encountered a retryable error. Will Retry with exponential backoff {:code=>413, :url=>"http://127.0.0.1:9200/_bulk"}`

and keeps trying until it fails with out of memory:  
`[ERROR][org.logstash.Logstash] java.lang.OutOfMemoryError: Java heap space`

Is there limit for such retries?

From plugin manual it is unclear what about retries for 413 errors:  
[https://www.elastic.co/guide/en/logstash/current/plugins-outputs-elasticsearch.html](https://www.elastic.co/guide/en/logstash/current/plugins-outputs-elasticsearch.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 19, 2020, 3:52pm UTC](https://discuss.elastic.co/t/logstash-stuck-on-will-retry-with-exponential-backoff/220221/2 "2020-03-19T15:52:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
