# Logstash terminate if using sqlite plugin

**URL:** <https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432>\
**Category:** Logstash\
**Created:** [October 17, 2015, 11:17am UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432 "2015-10-17T11:17:37Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![M.Tyler](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@M.Tyler](https://discuss.elastic.co/u/M.Tyler)\
**Post date:** [October 17, 2015, 11:17am UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/1 "2015-10-17T11:17:37Z")

</div>

Please let me question about sqlite plugin.

Logstash version: 1.5.4  
OS: Windows Vista

I set logstash.conf as the below on input section after I ran "bin/plugin install logstash-input-sqlite".  
But Logstash terminate immediately after execution.

---- @ logstash.conf ----  
input {  
sqlite {  
path =\> "C:/Program Files/sample/test.db"  
type =\> ACCESSLOG  
}  
}  
....  
---- @ logstash.conf ----

ACCESSLOG is table, which is in test.db.

Could you tell me workaround ?

Tyler

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 18, 2015, 11:37pm UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/2 "2015-10-18T23:37:42Z")

</div>

What do the LS logs show?

---

<div class="post-metadata">

**Author:** ![M.Tyler](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@M.Tyler](https://discuss.elastic.co/u/M.Tyler)\
**Post date:** [October 19, 2015, 3:45pm UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/3 "2015-10-19T15:45:05Z")

</div>

Hi Mark,

Thank you for your comment.

Logstash show the below logs.

----- @ logstash logs -----  
io/console not supported; tty will not be manipulated  
{:timestamp=\>"2015-10-20T00:34:39.688000+0900", :message=\>"A plugin had an unrecoverable error. Will restart this plugin.\n Plugin: \<LogStash::Inputs::Sqlite path=\>"C:\\\\Program Files\\\\sample\\\\test", type=\>"ACCESSLOG", debug=\>false, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, batch=\>5\>\n Error: Java::JavaSql::SQLException: [SQLITE\_ERROR] SQL error or missing database (no such column: id)", :level=\>:error}  
{:timestamp=\>"2015-10-20T00:34:41.779000+0900", :message=\>"A plugin had an unrecoverable error. Will restart this plugin.\n Plugin: \<LogStash::Inputs::Sqlite path=\>"C:\\\\Program Files\\\\sample\\\\test", type=\>"ACCESSLOG", debug=\>false, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, batch=\>5\>\n Error: Java::JavaSql::SQLException: [SQLITE\_ERROR] SQL error or missing database (no such column: id)", :level=\>:error}  
{:timestamp=\>"2015-10-20T00:34:42.793000+0900", :message=\>"A plugin had an unrecoverable error. Will restart this plugin.\n Plugin: \<LogStash::Inputs::Sqlite path=\>"C:\\\\Program Files\\\\sample\\\\test", type=\>"ACCESSLOG", debug=\>false, codec=\>\<LogStash::Codecs::Plain charset=\>"UTF-8"\>, batch=\>5\>\n Error: Java::JavaSql::SQLException: [SQLITE\_ERROR] SQL error or missing database (no such column: id)", :level=\>:error}  
----- @ logstash logs -----

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 19, 2015, 8:33pm UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/4 "2015-10-19T20:33:33Z")

</div>

> [@M.Tyler](#):
>
> no such column: id

That's your problem then.

---

<div class="post-metadata">

**Author:** ![M.Tyler](https://avatars.discourse-cdn.com/v4/letter/m/94ad74/32.png) [@M.Tyler](https://discuss.elastic.co/u/M.Tyler)\
**Post date:** [October 19, 2015, 11:23pm UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/5 "2015-10-19T23:23:45Z")

</div>

Thank you for your comment !

I understand that the issue is caused by no id column from the LS log.  
There is "id" although I confirmed table.  
Could you tell me what cause the issue ?

 ![](https://us1.discourse-cdn.com/elastic/original/2X/5/57b812a6c1dd3e5c070be6c8b5ec9074eba81932.jpg)

---

<div class="post-metadata">

**Author:** ![johtani](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/johtani/32/44956_2.png) [@johtani](https://discuss.elastic.co/u/johtani)\
**Post date:** [October 26, 2015, 12:58am UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/6 "2015-10-26T00:58:40Z")

</div>

You should read the document.  
[https://www.elastic.co/guide/en/logstash/current/plugins-inputs-sqlite.html](https://www.elastic.co/guide/en/logstash/current/plugins-inputs-sqlite.html)

**All tables are read by default except:**

If you don't read some tables, you should use "\* exclude\_tables\*".

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:25am UTC](https://discuss.elastic.co/t/logstash-terminate-if-using-sqlite-plugin/32432/7 "2017-07-06T05:25:26Z")

</div>


