# Logstash "The error reported is: \\n Permission denied - bind(2)"

**URL:** https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770
**Category:** Logstash
**Created:** [January 9, 2016, 12:37am UTC](https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770 "2016-01-09T00:37:31Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![shihab\_rabee](https://avatars.discourse-cdn.com/v4/letter/s/d26b3c/32.png) [@shihab\_rabee](https://discuss.elastic.co/u/shihab_rabee)
#### Post date: [January 9, 2016, 12:37am UTC](https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770/1 "2016-01-09T00:37:31Z")

</div>

Logstash fails to start when listining on port 80. although i am starting it with root user

logstash "The error reported is: \n Permission denied - bind(2)"

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [January 10, 2016, 12:38am UTC](https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770/2 "2016-01-10T00:38:51Z")

</div>

Can you provide more info please, what is the complete error, what does your config look like, what version are you on?

---

<div class="post-metadata">

### Author: ![shihab\_rabee](https://avatars.discourse-cdn.com/v4/letter/s/d26b3c/32.png) [@shihab\_rabee](https://discuss.elastic.co/u/shihab_rabee)
#### Post date: [January 10, 2016, 4:39am UTC](https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770/3 "2016-01-10T04:39:51Z")

</div>

Thanks for your reply

Actually this is the only error.

Following my config

input {

http {  
port =\> 80  
}

beats {  
port =\> 5000

# type =\> syslog

}  
file {  
path =\> "/var/log/httpd/\*"  
start\_position =\> beginning  
}

}  
output {  
elasticsearch {}  
stdout {}  
}

---

<div class="post-metadata">

### Author: ![theuntergeek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/theuntergeek/32/44961_2.png) [@theuntergeek](https://discuss.elastic.co/u/theuntergeek)
#### Post date: [January 10, 2016, 4:56am UTC](https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770/4 "2016-01-10T04:56:41Z")

</div>

That port 80 is the likely culprit. Programs can't bind to privileged ports, which are \<1024, unless run as root. This is not recommended for Logstash, either. I recommend you get your clients to use an unprivileged port.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 5:16am UTC](https://discuss.elastic.co/t/logstash-the-error-reported-is-n-permission-denied-bind-2/38770/5 "2017-07-06T05:16:14Z")

</div>


