# Logstash use the "--config.reload.automatic" fail

**URL:** <https://discuss.elastic.co/t/logstash-use-the-config-reload-automatic-fail/138316>\
**Category:** Logstash\
**Created:** [July 3, 2018, 6:58am UTC](https://discuss.elastic.co/t/logstash-use-the-config-reload-automatic-fail/138316 "2018-07-03T06:58:02Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sun\_changlong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sun_changlong/32/39036_2.png) [@sun\_changlong](https://discuss.elastic.co/u/sun_changlong)\
**Post date:** [July 3, 2018, 6:58am UTC](https://discuss.elastic.co/t/logstash-use-the-config-reload-automatic-fail/138316/1 "2018-07-03T06:58:02Z")

</div>

I use the bin/logstash -f sys.conf --config.reload.automatic run the logstash,The first time is normal operation，However, after I change the configuration file, logstash will report an error when reloading.

```
[ERROR][logstash.agent] Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Cannot reload pipeline, because the new pipeline is not reloadable", :backtrace=>nil}
```

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [July 3, 2018, 7:21am UTC](https://discuss.elastic.co/t/logstash-use-the-config-reload-automatic-fail/138316/2 "2018-07-03T07:21:22Z")

</div>

I don't think all plugins support reloads. You're probably using one that doesn't support it.

---

<div class="post-metadata">

**Author:** ![sun\_changlong](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sun_changlong/32/39036_2.png) [@sun\_changlong](https://discuss.elastic.co/u/sun_changlong)\
**Post date:** [July 3, 2018, 7:22am UTC](https://discuss.elastic.co/t/logstash-use-the-config-reload-automatic-fail/138316/3 "2018-07-03T07:22:45Z")

</div>

Logstash can sometimes reload the configuration file, but it is good or bad, I don’t know where the problem is.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 31, 2018, 7:22am UTC](https://discuss.elastic.co/t/logstash-use-the-config-reload-automatic-fail/138316/4 "2018-07-31T07:22:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
