# Logstash v1.5.2 crash

**URL:** <https://discuss.elastic.co/t/logstash-v1-5-2-crash/25579>\
**Category:** Logstash\
**Created:** [July 15, 2015, 6:03am UTC](https://discuss.elastic.co/t/logstash-v1-5-2-crash/25579 "2015-07-15T06:03:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![judy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/judy/32/3708_2.png) [@judy](https://discuss.elastic.co/u/judy)\
**Post date:** [July 15, 2015, 6:03am UTC](https://discuss.elastic.co/t/logstash-v1-5-2-crash/25579/1 "2015-07-15T06:03:36Z")

</div>

logstash plugin logstash was stopped due to a crash caused by the infinite. This workaround?

```
A plugin had an unrecoverable error. Will restart this plugin.
  Plugin: <LogStash::Inputs::File path=>["/usr1/s3/alpha/bz/*"], sincedb_path=>"/usr1/last-s3-file/alpha-bz-last-s3-file", start_position=>"beginning", delimiter=>"\n">
  Error: string not matched
  Exception: IndexError
  Stack: org/jruby/RubyString.java:3912:in `[]='
/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.2.2-java/lib/logstash/event.rb:73:in `initialize'
/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-codec-json-1.0.0/lib/logstash/codecs/json.rb:40:in `decode'
/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-1.0.0/lib/logstash/inputs/file.rb:138:in `run'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/tail.rb:184:in `_read_file'
org/jruby/RubyArray.java:1613:in `each'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/tail.rb:183:in `_read_file'
org/jruby/RubyKernel.java:1511:in `loop'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/tail.rb:179:in `_read_file'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/tail.rb:84:in `subscribe'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/watch.rb:67:in `each'
org/jruby/RubyArray.java:1613:in `each'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/watch.rb:64:in `each'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/watch.rb:117:in `subscribe'
/opt/logstash/vendor/bundle/jruby/1.9/gems/filewatch-0.6.4/lib/filewatch/tail.rb:75:in `subscribe'
/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-file-1.0.0/lib/logstash/inputs/file.rb:136:in `run'
/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.2.2-java/lib/logstash/pipeline.rb:176:in `inputworker'
/opt/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-1.5.2.2-java/lib/logstash/pipeline.rb:170:in `start_input' {:level=>:error, :file=>"logstash/pipeline.rb", :line=>"181", :method=>"inputworker"}
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:34am UTC](https://discuss.elastic.co/t/logstash-v1-5-2-crash/25579/2 "2017-07-06T05:34:43Z")

</div>


