# Logstash (v6.8.1) permission denied when importing csv file

**URL:** <https://discuss.elastic.co/t/logstash-v6-8-1-permission-denied-when-importing-csv-file/187027>\
**Category:** Logstash\
**Created:** [June 24, 2019, 12:55am UTC](https://discuss.elastic.co/t/logstash-v6-8-1-permission-denied-when-importing-csv-file/187027 "2019-06-24T00:55:13Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Scorpion21](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/scorpion21/32/48483_2.png) [@Scorpion21](https://discuss.elastic.co/u/Scorpion21)\
**Post date:** [June 24, 2019, 12:55am UTC](https://discuss.elastic.co/t/logstash-v6-8-1-permission-denied-when-importing-csv-file/187027/1 "2019-06-24T00:55:13Z")

</div>

I am a new starter to run Elastic Stac 6.8.1 on mac pro.  
These errors keeping on pop up, when I try to import csv file to elasticsearch via logstash.  
Does anyone know that is the root cause and how to fix that up?  
Thanks

[2019-06-24T10:43:26,561][ERROR][logstash.pipeline] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::File start\_position=\>"beginning", path=\>["/usr/local/Cellar/logstash-6.8.1/files/products.csv"], codec=\>\<LogStash::Codecs::Plain charset=\>"ISO-8859-1", id=\>"8732a739-9f87-46a2-a4ae-af018ed90f69", enable\_metric=\>true\>, id=\>"2b0c85a1cb8ebbe31b31ce2969c93ff851109c870d383abe533e8e7ea7476dee", sincedb\_path=\>"/dev/null", enable\_metric=\>true, stat\_interval=\>1.0, discover\_interval=\>15, sincedb\_write\_interval=\>15.0, delimiter=\>"\n", close\_older=\>3600.0, mode=\>"tail", file\_completed\_action=\>"delete", sincedb\_clean\_after=\>1209600.0, file\_chunk\_size=\>32768, file\_chunk\_count=\>140737488355327, file\_sort\_by=\>"last\_modified", file\_sort\_direction=\>"asc"\>  
Error: Permission denied - Permission denied  
Exception: Errno::EACCES

---

<div class="post-metadata">

**Author:** ![AquaX](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aquax/32/92006_2.png) [@AquaX](https://discuss.elastic.co/u/AquaX)\
**Post date:** [June 25, 2019, 6:21pm UTC](https://discuss.elastic.co/t/logstash-v6-8-1-permission-denied-when-importing-csv-file/187027/2 "2019-06-25T18:21:36Z")

</div>

Could be a couple of things, either your logstash instance does not have permission to delete the file or read the file, or both.

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 25, 2019, 6:31pm UTC](https://discuss.elastic.co/t/logstash-v6-8-1-permission-denied-when-importing-csv-file/187027/3 "2019-06-25T18:31:02Z")

</div>

> [@Scorpion21](#):
>
> mode=\>"tail", file\_completed\_action=\>"delete"

In tail mode file\_completed\_action does not apply, so it has to be an issue opening the file.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 23, 2019, 6:31pm UTC](https://discuss.elastic.co/t/logstash-v6-8-1-permission-denied-when-importing-csv-file/187027/4 "2019-07-23T18:31:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
