# Logstash with docker

**URL:** https://discuss.elastic.co/t/logstash-with-docker/222501
**Category:** Logstash
**Created:** [March 6, 2020, 6:44pm UTC](https://discuss.elastic.co/t/logstash-with-docker/222501 "2020-03-06T18:44:00Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![alxfernando](https://avatars.discourse-cdn.com/v4/letter/a/a88e4f/32.png) [@alxfernando](https://discuss.elastic.co/u/alxfernando)
#### Post date: [March 6, 2020, 6:44pm UTC](https://discuss.elastic.co/t/logstash-with-docker/222501/1 "2020-03-06T18:44:01Z")

</div>

This error appears when I run the kibana docker-compose, elastisearch, logstash

logstash | [2020-03-06T18:41:21,278][WARN][logstash.outputs.elasticsearch] Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>"[http://localhost:9200/](http://localhost:9200/)", :error\_type=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :error=\>"Elasticsearch Unreachable: [[http://localhost:9200/](http://localhost:9200/)][Manticore::SocketException] Connection refused (Connection refused)"}

the docker-compose is

version: '2.2'  
services:  
elasticsearch:  
image: [docker.elastic.co/elasticsearch/elasticsearch:7.5.1](http://docker.elastic.co/elasticsearch/elasticsearch:7.5.1)  
container\_name: elasticsearch  
environment:  
- cluster.name=es-docker-cluster  
- discovery.type=single-node  
- bootstrap.memory\_lock=true  
- "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
ulimits:  
memlock:  
soft: -1  
hard: -1  
volumes:  
- data01:/usr/share/elasticsearch/data  
ports:  
- 9200:9200  
- 9300:9300  
networks:  
- elasticstack

kibana:  
image: [docker.elastic.co/kibana/kibana:7.5.1](http://docker.elastic.co/kibana/kibana:7.5.1)  
container\_name: kibana  
ports:  
- 5601:5601  
environment:  
ELASTICSEARCH\_URL: [http://elasticsearch:9200](http://elasticsearch:9200)  
ELASTICSEARCH\_HOSTS: [http://elasticsearch:9200](http://elasticsearch:9200)  
networks:  
- elasticstack

logstash:  
image: [docker.elastic.co/logstash/logstash:7.5.1](http://docker.elastic.co/logstash/logstash:7.5.1)  
container\_name: logstash  
volumes:  
- /home/alex/Escritorio/prueba\_docker/pipeline:/usr/share/logstash/pipeline/  
command: logstash -f /usr/share/logstash/pipeline/  
#environment:  
# ELASTICSEARCH\_URL: [http://elasticsearch:9200](http://elasticsearch:9200)  
# ELASTICSEARCH\_HOSTS: [http://elasticsearch:9200](http://elasticsearch:9200)  
# - "ES\_JAVA\_OPTS=-Xms512m -Xmx512m"  
links:  
- elasticsearch:elasticsearch  
#depends\_on:  
# - elasticsearch  
networks:  
- elasticstack

volumes:  
data01:  
driver: local

networks:  
elasticstack:  
driver: bridge

and the logtash configuration file is

input {  
stdin {  
}  
}

output {  
elasticsearch {  
hosts =\> ["[http://localhost:9200](http://localhost:9200)"]  
}  
stdout {  
codec =\> rubydebug  
}  
}

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 3, 2020, 6:44pm UTC](https://discuss.elastic.co/t/logstash-with-docker/222501/2 "2020-04-03T18:44:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
