# Logstash with email output plugin "no such file to load -- net/smtp"

**URL:** https://discuss.elastic.co/t/logstash-with-email-output-plugin-no-such-file-to-load-net-smtp/343490
**Category:** Logstash
**Created:** [September 20, 2023, 8:05pm UTC](https://discuss.elastic.co/t/logstash-with-email-output-plugin-no-such-file-to-load-net-smtp/343490 "2023-09-20T20:05:25Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![lee.clemens](https://avatars.discourse-cdn.com/v4/letter/l/85f322/32.png) [@lee.clemens](https://discuss.elastic.co/u/lee.clemens)
#### Post date: [September 20, 2023, 8:05pm UTC](https://discuss.elastic.co/t/logstash-with-email-output-plugin-no-such-file-to-load-net-smtp/343490/1 "2023-09-20T20:05:25Z")

</div>

Hello,

I recently upgraded RHEL 9 from `logstash-8.8.2-1.x86_64` to `logstash-8.10.1-1.x86_64` and now logstash fails to start.

We are using the `email` output plugin and see this error in the logs:

```auto
[2023-09-20T13:48:49,401][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (LoadError) no such file to load -- net/smtp
org.jruby.exceptions.LoadError: (LoadError) no such file to load -- net/smtp

```

Undoing the `yum upgrade` restores functionality.

I don't see any additional packages available, but I'll also need to test the older version and confirm things were still working (perhaps failing to start is an improvement).

Any advice would be appreciated. Thanks,  
Lee

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [September 20, 2023, 8:28pm UTC](https://discuss.elastic.co/t/logstash-with-email-output-plugin-no-such-file-to-load-net-smtp/343490/2 "2023-09-20T20:28:39Z")

</div>

I don't have any advice, but you are [not](https://discuss.elastic.co/t/logstash-upgrade-and-8-10-1-net-snmp-error/343307) the only person seeing this.

---

<div class="post-metadata">

### Author: ![lee.clemens](https://avatars.discourse-cdn.com/v4/letter/l/85f322/32.png) [@lee.clemens](https://discuss.elastic.co/u/lee.clemens)
#### Post date: [September 20, 2023, 9:21pm UTC](https://discuss.elastic.co/t/logstash-with-email-output-plugin-no-such-file-to-load-net-smtp/343490/3 "2023-09-20T21:21:47Z")

</div>

Thanks for referencing that; the subject said snmp but it looks like it was a typo

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 18, 2023, 9:22pm UTC](https://discuss.elastic.co/t/logstash-with-email-output-plugin-no-such-file-to-load-net-smtp/343490/4 "2023-10-18T21:22:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
