# Logstash: With Oracle, scheduled pull, 503 error

**URL:** <https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949>\
**Category:** Logstash\
**Created:** [April 11, 2016, 7:04am UTC](https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949 "2016-04-11T07:04:16Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![krushnat\_khawale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krushnat_khawale/32/6652_2.png) [@krushnat\_khawale](https://discuss.elastic.co/u/krushnat_khawale)\
**Post date:** [April 11, 2016, 7:04am UTC](https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949/1 "2016-04-11T07:04:16Z")

</div>

I am trying to fetch data from oracle server in network which is a scheduled task.  
It is fetching data from database successfully but while inserting into Elasticsearch,  
following error is displayed.  
**Unable to understand the error,**

 ![](https://us1.discourse-cdn.com/elastic/original/2X/5/58c4dd115091069383cf06cb4bd10fb1e1b1a33b.png)

Following is my logstash configuration,

```
input {  
      jdbc {
	jdbc_driver_library => "D:/ES/logstash/bin/ojdbc14.jar"
        jdbc_driver_class => "Java::oracle.jdbc.driver.OracleDriver"
    	jdbc_connection_string => "jdbc:oracle:thin:@11.71.160.227:1521:xe"
    	jdbc_user => "kibana"
        jdbc_password => "kibana"
    	statement => "select * from info"
	schedule => "* * * * *"
    }
}

 
output {
    elasticsearch {
        hosts => "10.76.133.15:9200"
	action => "index"
        index => "ssession-%{+YYYY.MM.dd_HH:mm:ss}"
    }
    stdout { codec => rubydebug }
}

```

Has anybody have faced/solved to this problem?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 11, 2016, 7:19am UTC](https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949/2 "2016-04-11T07:19:13Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them.

If you can repost the actual error as text we should be able to help.

---

<div class="post-metadata">

**Author:** ![krushnat\_khawale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/krushnat_khawale/32/6652_2.png) [@krushnat\_khawale](https://discuss.elastic.co/u/krushnat_khawale)\
**Post date:** [April 11, 2016, 7:30am UTC](https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949/3 "2016-04-11T07:30:03Z")

</div>

@warkolm, As the output doesn't contain any error message, there is only one error message  
and that is, "INFLIGHT\_EVENT\_COUNT".  
Another error after this message shown is  
**mretrying failed action with response code: 503 {:level=\>:warn}←[0m**

The query returns records not more than 200.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 11, 2016, 7:43am UTC](https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949/4 "2016-04-11T07:43:46Z")

</div>

Please post the entire text, it has context that may be useful.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:02am UTC](https://discuss.elastic.co/t/logstash-with-oracle-scheduled-pull-503-error/46949/5 "2017-07-06T05:02:58Z")

</div>


