# Logstash WMI Plugin error

**URL:** <https://discuss.elastic.co/t/logstash-wmi-plugin-error/177297>\
**Category:** Logstash\
**Created:** [April 17, 2019, 1:23pm UTC](https://discuss.elastic.co/t/logstash-wmi-plugin-error/177297 "2019-04-17T13:23:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nyarlath](https://avatars.discourse-cdn.com/v4/letter/n/94ad74/32.png) [@nyarlath](https://discuss.elastic.co/u/nyarlath)\
**Post date:** [April 17, 2019, 1:24pm UTC](https://discuss.elastic.co/t/logstash-wmi-plugin-error/177297/1 "2019-04-17T13:24:00Z")

</div>

Hello,

I have Logstash installed on a RHEL. I Installed the WMI plugin (logstash-input-wmi) and tried to run it.  
I am facing the following issue :

```
[ERROR] 2019-04-17 12:43:07.765 [Converge PipelineAction::Create<main>] agent - Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}
[ERROR] 2019-04-17 12:43:07.897 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (LoadError) load error: win32ole/win32ole -- java.lang.UnsatisfiedLinkError: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/jruby-win32ole-0.8.5/lib/racob-x64.dll: /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/jruby-win32ole-0.8.5/lib/racob-x64.dll: invalid ELF header (Possible cause: endianness mismatch)

```

I see the Unsatisfied link error, but the file /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/jruby-win32ole-0.8.5/lib/racob-x64.dll is present :

`-rwxr-xr-x 1 root root 123392 Apr 17 12:25 /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/jruby-win32ole-0.8.5/lib/racob-x64.dll`

And my conf file is like this :

```
input {
  wmi { # Connect to a remote host
    query => "SELECT * FROM ApplicationPool"
    host => "MY-SERVER"
    user => "DOMAIN\user"
    password => "Password"
  }
}

output {
 elasticsearch {
    hosts => "localhost:9200"
    manage_template => false
    index => "wmi-%{+YYYY.MM.dd}"
  }
 stdout { codec => rubydebug }
}

```

What am i missing?

Thanks for your help

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 15, 2019, 1:24pm UTC](https://discuss.elastic.co/t/logstash-wmi-plugin-error/177297/2 "2019-05-15T13:24:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
