# Logstash Won't Start after Restart 6.2.2 load error: jopenssl

**URL:** <https://discuss.elastic.co/t/logstash-wont-start-after-restart-6-2-2-load-error-jopenssl/128020>\
**Category:** Logstash\
**Created:** [April 13, 2018, 8:13pm UTC](https://discuss.elastic.co/t/logstash-wont-start-after-restart-6-2-2-load-error-jopenssl/128020 "2018-04-13T20:13:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![devin.ferguson](https://avatars.discourse-cdn.com/v4/letter/d/97f17d/32.png) [@devin.ferguson](https://discuss.elastic.co/u/devin.ferguson)\
**Post date:** [April 13, 2018, 8:13pm UTC](https://discuss.elastic.co/t/logstash-wont-start-after-restart-6-2-2-load-error-jopenssl/128020/1 "2018-04-13T20:13:15Z")

</div>

Hello all!  
I am currently working on a test instance of logstash. It has been working fine until recently I did a service logstash restart because I change a configuration file slightly. Since then logstash won't start. It just continually restarts and posts this message to syslog.

```
logstash[6587]: [ERROR] 2018-04-13 15:06:48.901 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (LoadError) load error: jopenssl -- java.lang.RuntimeException: BUG: we can not copy embedded jar to temp directory

```

The server is running Ubuntu 16.04  
Logstash was installed using .deb

The configuration I changed was just removing a whole filter line from a conf.d file. The change shouldn't be causing this kind of error.  
Any help would be great!  
Thanks,  
Devin

---

<div class="post-metadata">

**Author:** ![devin.ferguson](https://avatars.discourse-cdn.com/v4/letter/d/97f17d/32.png) [@devin.ferguson](https://discuss.elastic.co/u/devin.ferguson)\
**Post date:** [April 13, 2018, 8:45pm UTC](https://discuss.elastic.co/t/logstash-wont-start-after-restart-6-2-2-load-error-jopenssl/128020/3 "2018-04-13T20:45:02Z")

</div>

I rebooted the server and now the error message has changed slightly.  
logstash[2669]: [ERROR] 2018-04-13 15:39:18.991 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (RuntimeError)  
logstash[2669]: #011you might need to reinstall the gem which depends on the missing jar or in case there is Jars.lock then resolve the jars with `lock_jars` command  
logstash[2669]: load error: org/bouncycastle/bcprov-jdk15on/1.56/bcprov-jdk15on-1.56 -- java.lang.RuntimeException: BUG: we can not copy embedded jar to temp directory (LoadError)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 11, 2018, 8:45pm UTC](https://discuss.elastic.co/t/logstash-wont-start-after-restart-6-2-2-load-error-jopenssl/128020/4 "2018-05-11T20:45:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
