# Logstash won't start: permission problem?

**URL:** <https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886>\
**Category:** Logstash\
**Created:** [November 8, 2017, 2:51pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886 "2017-11-08T14:51:18Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![hispeed](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hispeed/32/16232_2.png) [@hispeed](https://discuss.elastic.co/u/hispeed)\
**Post date:** [November 8, 2017, 2:51pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/1 "2017-11-08T14:51:18Z")

</div>

I have updated to ELK 5.4.6 now I get the following error when starting Logstash? Is this a permission problem? Any ideas where I have to search?

> [2017-11-08T15:44:24,340][FATAL][logstash.runner] An unexpected error occurred! {:error=\>java.nio.file.AccessDeniedException: /var/lib/logstash/.lock, :backtrace=\>["sun.nio.fs.UnixException.translateToIOException(sun/nio/fs/UnixException.java:84)", "sun.nio.fs.UnixException.rethrowAsIOException(sun/nio/fs/UnixException.java:102)", "sun.nio.fs.UnixException.rethrowAsIOException(sun/nio/fs/UnixException.java:107)", "sun.nio.fs.UnixFileSystemProvider.newFileChannel(sun/nio/fs/UnixFileSystemProvider.java:177)", "java.nio.channels.FileChannel.open(java/nio/channels/FileChannel.java:287)", "java.nio.channels.FileChannel.open(java/nio/channels/FileChannel.java:335)", "org.logstash.FileLockFactory.obtainLock(org/logstash/FileLockFactory.java:84)", "java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)", "RUBY.execute(/usr/share/logstash/logstash-core/lib/logstash/runner.rb:309)", "RUBY.run(/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67)", "RUBY.run(/usr/share/logstash/logstash-core/lib/logstash/runner.rb:204)", "RUBY.run(/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132)", "usr.share.logstash.lib.bootstrap.environment.(root)(/usr/share/logstash/lib/bootstrap/environment.rb:71)", "usr.share.logstash.lib.bootstrap.environment.(root)(usr/share/logstash/lib/bootstrap//usr/share/logstash/lib/bootstrap/environment.rb:71)"]}

Thanks for your help.

Marc

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 8, 2017, 4:17pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/2 "2017-11-08T16:17:14Z")

</div>

What user is Logstash running as? What permission and ownership does /var/lib/logstash/.lock and /var/lib/logstash have?

---

<div class="post-metadata">

**Author:** ![hispeed](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hispeed/32/16232_2.png) [@hispeed](https://discuss.elastic.co/u/hispeed)\
**Post date:** [November 8, 2017, 4:45pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/3 "2017-11-08T16:45:21Z")

</div>

I set for all of those folder CHMOD 777.  
I start logstash as root:  
root 3227 0.0 0.0 112644 964 pts/1 R+ 17:33 0:00 grep --color=auto logstash

Now i get the following message:

> [2017-11-08T17:40:40,217][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
> [2017-11-08T17:40:43,208][WARN][logstash.agent] stopping pipeline {:id=\>"main"}  
> [2017-11-08T17:40:43,219][FATAL][logstash.runner] An unexpected error occurred! {:error=\>#\<NoMethodError: undefined method `each' for nil:NilClass>, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-syslog-3.2.2/lib/logstash/inputs/syslog.rb:240:in `close\_tcp'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-input-syslog-3.2.2/lib/logstash/inputs/syslog.rb:225:in `stop'", "/usr/share/logstash/logstash-core/lib/logstash/inputs/base.rb:89:in `do\_stop'", "org/jruby/RubyArray.java:1613:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:513:in `shutdown'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:436:in `stop_pipeline'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:452:in `shutdown\_pipelines'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:452:in `shutdown\_pipelines'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:139:in `shutdown'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:328:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:204:in `run'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:71:in `(root)'"]}

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 9, 2017, 6:54am UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/4 "2017-11-09T06:54:45Z")

</div>

> I set for all of those folder CHMOD 777.

No, don't do that. There's no reason to give anyone but the Logstash user write access

> I start logstash as root:  
> root 3227 0.0 0.0 112644 964 pts/1 R+ 17:33 0:00 grep --color=auto logstash

Maybe you did start Logstash as root, but this line just proves that you ran `grep --color=auto logstash` as root.

Don't know what's up with the error you get.

---

<div class="post-metadata">

**Author:** ![hispeed](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hispeed/32/16232_2.png) [@hispeed](https://discuss.elastic.co/u/hispeed)\
**Post date:** [November 9, 2017, 5:53pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/5 "2017-11-09T17:53:37Z")

</div>

What kind of write settings should I set for those folders? I don't know what it was before....  
Do you know that?

Maybe it's a filter problem I found out thru google.

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 9, 2017, 9:40pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/6 "2017-11-09T21:40:40Z")

</div>

> What kind of write settings should I set for those folders? I don't know what it was before....

You'll want to run Logstash as the logstash user so just make sure that user has full access to the file and the directory it's in.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 7, 2017, 9:40pm UTC](https://discuss.elastic.co/t/logstash-wont-start-permission-problem/106886/7 "2017-12-07T21:40:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
