# Logstash.yml with keystore not working

**URL:** <https://discuss.elastic.co/t/logstash-yml-with-keystore-not-working/125726>\
**Category:** Logstash\
**Created:** [March 27, 2018, 9:56am UTC](https://discuss.elastic.co/t/logstash-yml-with-keystore-not-working/125726 "2018-03-27T09:56:25Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Izek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/izek/32/37113_2.png) [@Izek](https://discuss.elastic.co/u/Izek)\
**Post date:** [March 27, 2018, 9:56am UTC](https://discuss.elastic.co/t/logstash-yml-with-keystore-not-working/125726/1 "2018-03-27T09:56:25Z")

</div>

When I try to setup logstash x-pack with keystore , but I cannot make it  
I have already generate logstash.keystore file and add few records.  
but still not working

error as below:

logstash: ERROR: Failed to load settings file from "path.settings". Aborting... path.setting=/etc/logstash, exception=Java::OrgLogstashSecretStore::SecretStoreException::LoadException, message=\>Found a file at /etc/logstash/logstash.keystore, but it is not a valid Logstash keystore.  
logstash: [ERROR] 2018-03-27 17:53:59.683 [main] Logstash - java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit  
systemd: logstash.service: main process exited, code=exited, status=1/FAILURE

Config:

# ------------ xpack management settings ----------------

xpack.management.enabled: true  
xpack.management.elasticsearch.url: "[http://elk6:9200/](http://elk6:9200/)"  
xpack.management.logstash.poll\_interval: 5s  
xpack.management.pipeline.id: ["default"]  
xpack.management.elasticsearch.ssl.truststore.path: certificate/elastic-stack-ca.p12  
xpack.management.elasticsearch.ssl.truststore.password: ${LS\_SETTINGS\_DIR}/${xpack.management.elasticsearch.ssl.truststore.password}  
xpack.management.elasticsearch.ssl.keystore.path: certificate/elastic-stack-ca.p12  
xpack.management.elasticsearch.ssl.keystore.password: ${LS\_SETTINGS\_DIR}/${xpack.management.elasticsearch.ssl.keystore.password}

# ------------ xpack monitoring settings ----------------

xpack.monitoring.elasticsearch.url: "[http://elk6:9200/](http://elk6:9200/)"  
xpack.monitoring.elasticsearch.ssl.truststore.path: certificate/elastic-stack-ca.p12  
xpack.monitoring.elasticsearch.ssl.truststore.password: ${xpack.monitoring.elasticsearch.ssl.truststore.password}  
xpack.monitoring.collection.interval: 30s  
xpack.monitoring.elasticsearch.ssl.keystore.path: certificate/elastic-stack-ca.p12  
xpack.monitoring.elasticsearch.ssl.keystore.password: ${xpack.monitoring.elasticsearch.ssl.keystore.password}

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 24, 2018, 9:56am UTC](https://discuss.elastic.co/t/logstash-yml-with-keystore-not-working/125726/2 "2018-04-24T09:56:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
