# Logstash YUM installation issue!

**URL:** <https://discuss.elastic.co/t/logstash-yum-installation-issue/110105>\
**Category:** Logstash\
**Created:** [December 4, 2017, 9:34am UTC](https://discuss.elastic.co/t/logstash-yum-installation-issue/110105 "2017-12-04T09:34:43Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![SJN8](https://avatars.discourse-cdn.com/v4/letter/s/f08c70/32.png) [@SJN8](https://discuss.elastic.co/u/SJN8)\
**Post date:** [December 4, 2017, 9:34am UTC](https://discuss.elastic.co/t/logstash-yum-installation-issue/110105/1 "2017-12-04T09:34:43Z")

</div>

Hi All,

I am trying to install logstash with YUM package method ,

But i am facing below issue ,

sudo yum update logstash  
Loaded plugins: aliases, changelog, fastestmirror, kabi, langpacks, tmprepo, verify, versionlock  
Loading support for Red Hat kernel ABI  
Repository logstash-6.x is listed more than once in the configuration  
[http://mhxrpmsrv001sas.dsone.3ds.com/rpms/cent/7\_3\_1611/x86\_64/os/latest/repodata/repomd.xml:](http://mhxrpmsrv001sas.dsone.3ds.com/rpms/cent/7_3_1611/x86_64/os/latest/repodata/repomd.xml:) [Errno 14] HTTP Error 404 - Not Found  
Trying other mirror.  
To address this issue please refer to the below knowledge base article

[https://access.redhat.com/articles/1320623](https://access.redhat.com/articles/1320623)

If above article doesn't help to resolve this issue please create a bug on [https://bugs.centos.org/](https://bugs.centos.org/)

One of the configured repositories failed (CentOS-7\_3\_1611 - os),  
and yum doesn't have enough cached data to continue. At this point the only  
safe thing yum can do is fail. There are a few ways to work "fix" this:

```
 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=cent-7_3_1611-os ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable cent-7_3_1611-os
    or
        subscription-manager repos --disable=cent-7_3_1611-os

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=cent-7_3_1611-os.skip_if_unavailable=true

```

failure: repodata/repomd.xml from cent-7\_3\_1611-os: [Errno 256] No more mirrors to try.  
[http://mhxrpmsrv001sas.dsone.3ds.com/rpms/cent/7\_3\_1611/x86\_64/os/latest/repodata/repomd.xml:](http://mhxrpmsrv001sas.dsone.3ds.com/rpms/cent/7_3_1611/x86_64/os/latest/repodata/repomd.xml:) [Errno 14] HTTP Error 404 - Not Found

I have followed all steps mentioned ,

YUM

Download and install the public signing key:

rpm --import [https://artifacts.elastic.co/GPG-KEY-elasticsearch](https://artifacts.elastic.co/GPG-KEY-elasticsearch)

Add the following in your /etc/yum.repos.d/ directory in a file with a .repo suffix, for example logstash.repo

[logstash-6.x]  
name=Elastic repository for 6.x packages  
baseurl=https://artifacts.elastic.co/packages/6.x/yum  
gpgcheck=1  
gpgkey=https://artifacts.elastic.co/GPG-KEY-elasticsearch  
enabled=1  
autorefresh=1  
type=rpm-md

And your repository is ready for use. You can install it with:

sudo yum install logstash

Please help on the same

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 4, 2017, 9:47am UTC](https://discuss.elastic.co/t/logstash-yum-installation-issue/110105/2 "2017-12-04T09:47:42Z")

</div>

> [@SJN8](#):
>
> failure: repodata/repomd.xml from cent-7\_3\_1611-os: [Errno 256] No more mirrors to try.
> 
> [http://mhxrpmsrv001sas.dsone.3ds.com/rpms/cent/7\_3\_1611/x86\_64/os/latest/repodata/repomd.xml:](http://mhxrpmsrv001sas.dsone.3ds.com/rpms/cent/7_3_1611/x86_64/os/latest/repodata/repomd.xml:) [Errno 14] HTTP Error 404 - Not Found

Looks like that is the problem, did you try removing it?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 1, 2018, 9:48am UTC](https://discuss.elastic.co/t/logstash-yum-installation-issue/110105/3 "2018-01-01T09:48:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
