# Logstash

**URL:** <https://discuss.elastic.co/t/logstash/245152>\
**Category:** Logstash\
**Created:** [August 16, 2020, 3:47pm UTC](https://discuss.elastic.co/t/logstash/245152 "2020-08-16T15:47:46Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![shashanksingh](https://avatars.discourse-cdn.com/v4/letter/s/e9c0ed/32.png) [@shashanksingh](https://discuss.elastic.co/u/shashanksingh)\
**Post date:** [August 16, 2020, 3:47pm UTC](https://discuss.elastic.co/t/logstash/245152/1 "2020-08-16T15:47:46Z")

</div>

hi , i am new to elastic stack . i am configuring filebeat logstash elasticsearch kibana. and i am getting some error. please help me as soon as possible. thank you.

root@ip-10-0-1-187:~# sudo /usr/share/logstash/bin/logstash -e 'input { stdin{ } } output { stdout{ } }'  
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.  
WARNING: An illegal reflective access operation has occurred  
WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/usr/share/logstash/logstash-core/lib/jars/jruby-complete-9.2.11.1.jar) to method sun.nio.ch.NativeThread.signal(long)  
WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules  
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations  
WARNING: All illegal access operations will be denied in a future release  
WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path /usr/share/logstash/config/log4j2.properties. Using default config which logs errors to the console  
[WARN] 2020-08-16 15:26:53.456 [LogStash::Runner] multilocal - Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[FATAL] 2020-08-16 15:26:53.466 [LogStash::Runner] runner - Logstash could not be started because there is already another instance using the configured data directory. If you wish to run multiple instances, you must change the "path.data" setting.  
[ERROR] 2020-08-16 15:26:53.468 [LogStash::Runner] Logstash - java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

---

<div class="post-metadata">

**Author:** ![aaron-nimocks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aaron-nimocks/32/73965_2.png) [@aaron-nimocks](https://discuss.elastic.co/u/aaron-nimocks)\
**Post date:** [August 16, 2020, 6:54pm UTC](https://discuss.elastic.co/t/logstash/245152/2 "2020-08-16T18:54:18Z")

</div>

Looks like Logstash is running already.

```auto
ps -ef | grep logstash

```

Run that and see if there is an instance still running. If so kill it and run again. Use CTRL C to break a logstash pipeline if it doesn't terminate automatically. If not then it can lead to this again.

- Not sure what command to use if running Windows.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 13, 2020, 8:54pm UTC](https://discuss.elastic.co/t/logstash/245152/3 "2020-09-13T20:54:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
