# Logstashサービス起動後、数秒で停止する

**URL:** <https://discuss.elastic.co/t/logstash/52995>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [June 16, 2016, 12:30pm UTC](https://discuss.elastic.co/t/logstash/52995 "2016-06-16T12:30:27Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![koichi](https://avatars.discourse-cdn.com/v4/letter/k/f1d935/32.png) [@koichi](https://discuss.elastic.co/u/koichi)\
**Post date:** [June 16, 2016, 12:30pm UTC](https://discuss.elastic.co/t/logstash/52995/1 "2016-06-16T12:30:27Z")

</div>

お世話になります。  
/etc/logstash/conf.d/配下にlogstashのconfigファイルを  
配置し、サーバ起動時にlogstashを自動起動していました。

こちらのconfigリロード設定を試した時頃から  
logstashのサービスがいつの間にか停止するようになりました。  
[https://www.elastic.co/guide/en/logstash/current/reloading-config.html](https://www.elastic.co/guide/en/logstash/current/reloading-config.html)

# 以下に事象発生時の例です。

# date

Thu Jun 16 21:25:15 JST 2016

# service logstash status

logstash is not running

# date

Thu Jun 16 21:25:28 JST 2016

# service logstash start

logstash started.

# date

Thu Jun 16 21:25:39 JST 2016

# service logstash status

logstash is running

# date

Thu Jun 16 21:25:47 JST 2016

# service logstash status

logstash is not running

# date

# Thu Jun 16 21:25:54 JST 2016

以下の2点について教えていただければ幸いです。

1. この事象はリロード設定の変更が原因か
2. このような事象が起こった際に確認する設定項目

環境は以下の通りです。

・JDK 1.8.9  
・Elasticsearch 2.3.1  
・Logstash 2.3.1  
・Kibana 4.5.0

以上よろしくお願いします。

---

<div class="post-metadata">

**Author:** ![johtani](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/johtani/32/44956_2.png) [@johtani](https://discuss.elastic.co/u/johtani)\
**Post date:** [June 18, 2016, 9:05am UTC](https://discuss.elastic.co/t/logstash/52995/2 "2016-06-18T09:05:54Z")

</div>

この間に設定ファイルを書き換えたりはしていますか？  
その時に利用した設定ファイルにエラーが発生するようなものはないでしょうか？  
ログなどにエラーは出てないですか？

---

<div class="post-metadata">

**Author:** ![koichi](https://avatars.discourse-cdn.com/v4/letter/k/f1d935/32.png) [@koichi](https://discuss.elastic.co/u/koichi)\
**Post date:** [June 20, 2016, 1:41am UTC](https://discuss.elastic.co/t/logstash/52995/3 "2016-06-20T01:41:18Z")

</div>

返信いただきありがとうございます。

エラーログを確認したところ  
Errno::EACCES: Permission denied と出力されており  
/var/log/logstash/backup/配下の特定ファイルのユーザー/グループ権限によるものでした。

起動スクリプト/etc/rc.d/init.d/logstashのLS\_USERとLS\_GROUPの値と  
/var/log/logstash/backup/配下の特定のファイルのユーザー/グループ権限を一致させたところ  
数秒でlogstashのサービスが停止することがなくなりました。

設定ファイルの書き換えは特に行っていないと思われますが、  
auto reloadのコマンドを試した際に設定ファイルが書き換わったのかもしれません。

原因は突き止めきれてはいませんが、一旦サービスが起動しましたので報告いたします。

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:47pm UTC](https://discuss.elastic.co/t/logstash/52995/4 "2017-07-06T13:47:35Z")

</div>


