# Logstatsh plugins issue

**URL:** <https://discuss.elastic.co/t/logstatsh-plugins-issue/102404>\
**Category:** Logstash\
**Created:** [October 2, 2017, 5:25am UTC](https://discuss.elastic.co/t/logstatsh-plugins-issue/102404 "2017-10-02T05:25:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Blason](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blason/32/42284_2.png) [@Blason](https://discuss.elastic.co/u/Blason)\
**Post date:** [October 2, 2017, 5:25am UTC](https://discuss.elastic.co/t/logstatsh-plugins-issue/102404/1 "2017-10-02T05:25:39Z")

</div>

Hi Guys,

How do I run plugins with logstash? I mean I tried entering below setting in my /etc/logstash/logstash.yml but after restarting its not picking up the desired setting and my netflow ports not listing.

However when I run from command line with this option is does comes up properly. I am getting below error message in /var/log/messages.

Please help

```auto
### logstash.yml
modules:
   -name: netflow
    var.input.udp.port: 2055
    var.elasticsearch.hosts="172.16.3.69:9200"
    var.kibana.host="172.16.3.69:5601"

```

```auto
####From Cli
/usr/share/logstash/bin/logstash --modules=netflow -M netflow.var.elasticsearch.hosts="172.16.3.69:9200" -M netflow.var.kibana.host="172.16.3.69:5601" &

```

```auto
### Error
n"}
[2017-10-02T18:42:58,012][INFO][logstash.agent] No config files found in path {:path=>"/etc/logstash/conf.d/*"}
[2017-10-02T18:42:58,017][ERROR][logstash.agent] failed to fetch pipeline configuration {:message=>"No config files found: /etc/logstash/conf.d. Can you make sure this path is a logstash config file?"}
[2017-10-02T18:43:08,393][INFO][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"/usr/share/logstash/modules/fb_apache/configuration"}
[2017-10-02T18:43:08,396][INFO][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"/usr/share/logstash/modules/netflow/configuration"}
[2017-10-02T18:43:08,532][INFO][logstash.agent] No config files found in path {:path=>"/etc/logstash/conf.d/*"}
[2017-10-02T18:43:08,535][ERROR][logstash.agent] failed to fetch pipeline configuration {:message=>"No config files found: /etc/logstash/conf.d. Can you make sure this path is a logstash config file?"}

```

yeah I know conf.d does not yet contain any configuation file and can be ignored.

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [October 2, 2017, 5:52am UTC](https://discuss.elastic.co/t/logstatsh-plugins-issue/102404/2 "2017-10-02T05:52:10Z")

</div>

It seems Logstash really wants you to have at least one configuration file in /etc/logstash/conf.d even though you're using a netflow module.

---

<div class="post-metadata">

**Author:** ![Blason](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/blason/32/42284_2.png) [@Blason](https://discuss.elastic.co/u/Blason)\
**Post date:** [October 2, 2017, 6:05am UTC](https://discuss.elastic.co/t/logstatsh-plugins-issue/102404/3 "2017-10-02T06:05:54Z")

</div>

Well thats ok surprising thing is even after restarting the settings from logstash.yml are not being picked up hence wondering if the settings from /etc/logstash or /usr/share/logstash/configuration are being picked up.

I am really confused here.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 30, 2017, 6:06am UTC](https://discuss.elastic.co/t/logstatsh-plugins-issue/102404/4 "2017-10-30T06:06:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
