# Looks like you either have a bad certificate, an invalid key or your private key was not in PKCS8 format in logstash

**URL:** <https://discuss.elastic.co/t/looks-like-you-either-have-a-bad-certificate-an-invalid-key-or-your-private-key-was-not-in-pkcs8-format-in-logstash/261627>\
**Category:** Logstash\
**Created:** [January 20, 2021, 10:12am UTC](https://discuss.elastic.co/t/looks-like-you-either-have-a-bad-certificate-an-invalid-key-or-your-private-key-was-not-in-pkcs8-format-in-logstash/261627 "2021-01-20T10:12:37Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [January 20, 2021, 10:12am UTC](https://discuss.elastic.co/t/looks-like-you-either-have-a-bad-certificate-an-invalid-key-or-your-private-key-was-not-in-pkcs8-format-in-logstash/261627/1 "2021-01-20T10:12:37Z")

</div>

Hi Team,  
Im using below configuration in logstash beats and im getting below error,

Could anyone help to resolve this issue,

```
input {

        beats {
                port => 5044
                host => server"
                ssl => true
                ssl_certificate => "/opt/ls_home/logstash/config/certs/server.crt.pem"
                ssl_key => "/opt/ls_home/logstash/config/certs/server.key.p8"
                ssl_key_passphrase => "bAy?t6bHX)T%GCjdrEtz8cXe"
                ssl_certificate_authorities => "/opt/ls_home/logstash/config/certs/trust_chain.pem"
                ssl_verify_mode => "none"

        }

}

```

Getting below error in logstash:

> [2021-01-20T10:09:29,915][ERROR][logstash.inputs.beats] Looks like you either have a bad certificate, an invalid key or your private key was not in PKCS8 format.  
> [2021-01-20T10:09:29,915][WARN][io.netty.channel.ChannelInitializer] Failed to initialize a channel. Closing: [id: 0x1a8f87d8, L:/ip:5044 - R:/ip:57287]  
> java.lang.IllegalArgumentException: File does not contain valid private key: /opt/ls\_home/logstash/config/certs/cbgplstapr01.boigroup.net.key.p8  
> at io.netty.handler.ssl.SslContextBuilder.keyManager(SslContextBuilder.java:267) ~[netty-all-4.1.18.Final.jar:4.1.18.Final]  
> at io.netty.handler.ssl.SslContextBuilder.forServer(SslContextBuilder.java:90) ~[netty-all-4.1.18.Final.jar:4.1.18.Final]  
> at org.logstash.netty.SslSimpleBuilder.build(SslSimpleBuilder.java:112) ~[logstash-input-beats-5.1.6.jar:?]  
> at org.logstash.beats.Server$BeatsInitializer.initChannel(Server.java:131) ~[logstash-input-beats-5.1.6.jar:?]  
> at org.logstash.beats.Server$BeatsInitializer.initChannel(Server.java:101) [logstash-input-beats-5.1.6.jar:?]  
> at io.netty.channel.ChannelInitializer.initChannel(ChannelInitializer.java:113) [netty-all-4.1.18.Final.jar:4.1.18.Final]

Could anyone help us to resolve that above issue

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 17, 2021, 10:12am UTC](https://discuss.elastic.co/t/looks-like-you-either-have-a-bad-certificate-an-invalid-key-or-your-private-key-was-not-in-pkcs8-format-in-logstash/261627/2 "2021-02-17T10:12:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
