# \[lpseg2p\] \[spc\]\[0\], node\[r1Sz\_DsNSZ-wbxR35IPMpg\], \[P\], v\[20\], s\[STARTED\], a\[id=DEhEGi5WRZG5DiEHg7uvUw\]: failed to execute \[org.elasticsearch.action.percolate.PercolateRequest@350ed365\] RemoteTransportException\[\[lpseg2p\]\[11.22.23.19:9300\]\[indices:data/read

**URL:** https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702
**Category:** Elasticsearch
**Tags:** elastic-stack-alerting
**Created:** [February 7, 2024, 6:56am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702 "2024-02-07T06:56:15Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![mobistar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mobistar/32/131502_2.png) [@mobistar](https://discuss.elastic.co/u/mobistar)
#### Post date: [February 7, 2024, 6:56am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702/1 "2024-02-07T06:56:15Z")

</div>

Hi Friend,  
I am getting given erron on elasticsearch can some one help to resove it.  
It have a big data on shared and we just recover shard [0] after renaming translog directory

\BR  
Manoj Kumar

---

<div class="post-metadata">

### Author: ![mobistar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mobistar/32/131502_2.png) [@mobistar](https://discuss.elastic.co/u/mobistar)
#### Post date: [February 7, 2024, 6:57am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702/2 "2024-02-07T06:57:17Z")

</div>

` nested: IllegalStateException[can't load global ordinals for reader of type: class org.apache.lucene.index.memory.MemoryIndex$MemoryIndexReader must be a DirectoryReader];`

This is the main error

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [February 7, 2024, 7:00am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702/3 "2024-02-07T07:00:17Z")

</div>

Which version of Elasticsearch are you using?

> [@mobistar](#):
>
> we just recover shard [0] after renaming translog directory

What exactly did you do? What caused this?

---

<div class="post-metadata">

### Author: ![mobistar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mobistar/32/131502_2.png) [@mobistar](https://discuss.elastic.co/u/mobistar)
#### Post date: [February 7, 2024, 8:59am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702/4 "2024-02-07T08:59:58Z")

</div>

i am using elasticsearch 2.3.2  
java version 1.7.0.291

Problem arise when we saw heap error Elasticsearch log  
then we restart Elasticsearch after increasing max and min memory and after that  
index shard [0] was failed to recover data  
we tried to fix it and got a solution over internet  
we rename trans log and later copy system from renamed trans logs  
after that shard [0] is recovered successfully  
Now heap is increasing every day  
once it reaches to more than 90 percent shown posted error

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [February 7, 2024, 9:02am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702/5 "2024-02-07T09:02:40Z")

</div>

That version is ancient and has been EOL a very, very long time. I have not used it in a very long time so will not be able to help.

I would recommend you upgrade to the latest version as a matter of urgency.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 6, 2024, 9:03am UTC](https://discuss.elastic.co/t/lpseg2p-spc-0-node-r1sz-dsnsz-wbxr35ipmpg-p-v-20-s-started-a-id-dehegi5wrzg5diehg7uvuw-failed-to-execute-org-elasticsearch-action-percolate-percolaterequest-350ed365-remotetransportexception-lpseg2p-11-22-23-19-9300-indices-data-read/352702/6 "2024-03-06T09:03:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
