# Lumberjack Input Ceasing to Function

**URL:** <https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517>\
**Category:** Logstash\
**Created:** [August 17, 2015, 3:42pm UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517 "2015-08-17T15:42:54Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![davisv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davisv/32/4255_2.png) [@davisv](https://discuss.elastic.co/u/davisv)\
**Post date:** [August 17, 2015, 3:42pm UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517/1 "2015-08-17T15:42:54Z")

</div>

Hello all!

I'm running several logstash-forwarder instances on remote servers that connect back to a central ELK machine. Events from all logstash-forwarder instances process fine for the majority of the time but seemingly at random logstash stops processing events and generates the following error:

{:timestamp=\>"2015-08-17T04:02:43.983000-0600", :message=\>"CircuitBreaker::rescuing exceptions", :name=\>"Lumberjack input", :exception=\>LogStash::SizedQueueTimeout::TimeoutError, :level=\>:warn}  
{:timestamp=\>"2015-08-17T04:02:43.984000-0600", :message=\>"CircuitBreaker::Open", :name=\>"Lumberjack input", :level=\>:warn}  
{:timestamp=\>"2015-08-17T04:02:43.986000-0600", :message=\>"Exception in lumberjack input thread", :exception=\>#\<LogStash::CircuitBreaker::OpenBreaker: for Lumberjack input\>, :level=\>:error}  
{:timestamp=\>"2015-08-17T04:03:21.181000-0600", :message=\>"CircuitBreaker::rescuing exceptions", :name=\>"Lumberjack input", :exception=\>LogStash::SizedQueueTimeout::TimeoutError, :level=\>:warn}  
{:timestamp=\>"2015-08-17T04:03:21.184000-0600", :message=\>"CircuitBreaker::Open", :name=\>"Lumberjack input", :level=\>:warn}

My logstash config is as follows:

input {  
lumberjack {  
port =\> 5043  
ssl\_certificate =\> "/etc/pki/tls/certs/logstash-forwarder.crt"  
ssl\_key =\> "/etc/pki/tls/private/logstash-forwarder.key"  
}  
}

filter {  
if "Connection from UDP:" in [message] {  
drop {}  
}  
if "INPUT pkt died:" in [message] {  
drop {}  
}  
if [file] == "/var/log/messages" {  
grok {  
match =\> ["message", "%{SYSLOGTIMESTAMP:event\_timestamp} %{WORD:hostname} %{GREEDYDATA:message\_remainder}"]  
}  
}  
}

output {  
redis {  
data\_type =\> "list"  
key =\> "logstash"  
}  
stdout {}  
if [file] == "/var/log/messages" {  
file {  
path =\> "/var/log/logstash/messages"  
message\_format =\> "%{event\_timestamp} %{host} %{message\_remainder}"  
}  
}  
}

Any ideas as to why this happens? No other errors appear in logstash logs or in logstash-forwarder logs.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 17, 2015, 10:47pm UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517/2 "2015-08-17T22:47:31Z")

</div>

What versions are you on?

---

<div class="post-metadata">

**Author:** ![davisv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davisv/32/4255_2.png) [@davisv](https://discuss.elastic.co/u/davisv)\
**Post date:** [August 18, 2015, 3:36pm UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517/3 "2015-08-18T15:36:14Z")

</div>

Logstash - 1.5.2  
Logstash-Forwarder - 0.3.1

CentOS 6 on all involved machines

---

<div class="post-metadata">

**Author:** ![Woodrow9003](https://avatars.discourse-cdn.com/v4/letter/w/47e85d/32.png) [@Woodrow9003](https://discuss.elastic.co/u/Woodrow9003)\
**Post date:** [August 18, 2015, 3:38pm UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517/4 "2015-08-18T15:38:35Z")

</div>

(Working along with davisv) We are also running elastic 1.7.1. Upgrading to logstash 1.5.3 did not help this issue.

---

<div class="post-metadata">

**Author:** ![rawill](https://avatars.discourse-cdn.com/v4/letter/r/3ab097/32.png) [@rawill](https://discuss.elastic.co/u/rawill)\
**Post date:** [October 2, 2015, 5:00pm UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517/5 "2015-10-02T17:00:30Z")

</div>

Seeing the same issue on 1.5.4 with lumberjack input plugin version 1.0.4.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:27am UTC](https://discuss.elastic.co/t/lumberjack-input-ceasing-to-function/27517/6 "2017-07-06T05:27:26Z")

</div>


