# "main ERROR Null object" after update 5.6.1 =\> 6.0.1

**URL:** <https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057>\
**Category:** Elasticsearch\
**Created:** [December 11, 2017, 10:01am UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057 "2017-12-11T10:01:30Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jelen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jelen/32/25303_2.png) [@Jelen](https://discuss.elastic.co/u/Jelen)\
**Post date:** [December 11, 2017, 10:01am UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/1 "2017-12-11T10:01:30Z")

</div>

Hello,

after updating elastic, I get this error:

```
root@Lisa:~# service elasticsearch status
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2017-12-11 09:51:23 UTC; 8min ago
     Docs: http://www.elastic.co
  Process: 2250 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 2250 (code=exited, status=1/FAILURE)

Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,532 main ERROR Null object returned for RollingFile in Appenders.
Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,532 main ERROR Null object returned for RollingFile in Appenders.
Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,533 main ERROR Null object returned for RollingFile in Appenders.
Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,533 main ERROR Unable to locate appender "rolling" for logger config "root"
Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,537 main ERROR Unable to locate appender "index_indexing_slowlog_rolling" for logger config "index.indexing.slowlog.index"
Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,537 main ERROR Unable to locate appender "index_search_slowlog_rolling" for logger config "index.search.slowlog"
Dec 11 09:51:23 Lisa elasticsearch[2250]: 2017-12-11 09:51:23,539 main ERROR Unable to locate appender "deprecation_rolling" for logger config "org.elasticsearch.deprecation"
Dec 11 09:51:23 Lisa systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Dec 11 09:51:23 Lisa systemd[1]: elasticsearch.service: Unit entered failed state.
Dec 11 09:51:23 Lisa systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

```

There were just this issue and i keep the original one (old) [https://pastebin.com/qHXEQLnb](https://pastebin.com/qHXEQLnb). How can be fixed this?  
Ubuntu 16.04.2 LTS

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [December 11, 2017, 5:11pm UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/2 "2017-12-11T17:11:34Z")

</div>

I think that something is not right with your `log4j2.properties`. Can you share it?

---

<div class="post-metadata">

**Author:** ![Jelen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jelen/32/25303_2.png) [@Jelen](https://discuss.elastic.co/u/Jelen)\
**Post date:** [December 11, 2017, 5:37pm UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/3 "2017-12-11T17:37:06Z")

</div>

In `elasticsearch.yml` were `path.logs: /path/to/logs` and `path.logs: /path/to/data` paths. So I'd fixed them. But I'm surprised that the error message was not clearer. `Error: wrong or missing log directory "path/to/logs"` etc.

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [December 11, 2017, 5:49pm UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/4 "2017-12-11T17:49:53Z")

</div>

I am not sure what you mean, if I reproduce your situation I see:

```auto
2017-12-11 12:48:58,488 main ERROR Null object returned for RollingFile in Appenders.
2017-12-11 12:48:58,489 main ERROR Null object returned for RollingFile in Appenders.
2017-12-11 12:48:58,489 main ERROR Null object returned for RollingFile in Appenders.
2017-12-11 12:48:58,489 main ERROR Null object returned for RollingFile in Appenders.
2017-12-11 12:48:58,491 main ERROR Unable to locate appender "rolling" for logger config "root"
2017-12-11 12:48:58,491 main ERROR Unable to locate appender "index_indexing_slowlog_rolling" for logger config "index.indexing.slowlog.index"
2017-12-11 12:48:58,491 main ERROR Unable to locate appender "index_search_slowlog_rolling" for logger config "index.search.slowlog"
2017-12-11 12:48:58,491 main ERROR Unable to locate appender "deprecation_rolling" for logger config "org.elasticsearch.deprecation"
[2017-12-11T12:48:58,576][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: Unable to access 'path.logs' (/tmp/private)
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:134) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:121) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:69) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) ~[elasticsearch-6.0.1.jar:6.0.1]
Caused by: java.lang.IllegalStateException: Unable to access 'path.logs' (/tmp/private)
	at org.elasticsearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:70) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:286) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:248) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Security.configure(Security.java:121) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:207) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:322) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:130) ~[elasticsearch-6.0.1.jar:6.0.1]
	... 6 more
Caused by: java.nio.file.AccessDeniedException: /tmp/private
	at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84) ~[?:1.8.0_144]
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) ~[?:1.8.0_144]
	at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) ~[?:1.8.0_144]
	at sun.nio.fs.UnixFileSystemProvider.checkAccess(UnixFileSystemProvider.java:308) ~[?:1.8.0_144]
	at org.elasticsearch.bootstrap.Security.ensureDirectoryExists(Security.java:403) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:68) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:286) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:248) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Security.configure(Security.java:121) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:207) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:322) ~[elasticsearch-6.0.1.jar:6.0.1]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:130) ~[elasticsearch-6.0.1.jar:6.0.1]

```

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [December 11, 2017, 5:55pm UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/5 "2017-12-11T17:55:40Z")

</div>

I think that instead of `service elasticsearch status` you would see the same if you checked `journalctl -u elasticsearch`.

---

<div class="post-metadata">

**Author:** ![Jelen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jelen/32/25303_2.png) [@Jelen](https://discuss.elastic.co/u/Jelen)\
**Post date:** [December 12, 2017, 3:41pm UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/6 "2017-12-12T15:41:55Z")

</div>

Here is my output since yesterday till now - [https://pastebin.com/xEdc7KLU](https://pastebin.com/xEdc7KLU) `AccessDeniedException` not found in it. But I think that you find something else that could lead to wrong path in settings.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 9, 2018, 3:54pm UTC](https://discuss.elastic.co/t/main-error-null-object-after-update-5-6-1-6-0-1/111057/7 "2018-01-09T15:54:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
