# Make Plugin Backward Compataible

**URL:** <https://discuss.elastic.co/t/make-plugin-backward-compataible/191003>\
**Category:** Kibana\
**Created:** [July 17, 2019, 1:20pm UTC](https://discuss.elastic.co/t/make-plugin-backward-compataible/191003 "2019-07-17T13:20:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dkelsen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dkelsen/32/46291_2.png) [@dkelsen](https://discuss.elastic.co/u/dkelsen)\
**Post date:** [July 17, 2019, 1:20pm UTC](https://discuss.elastic.co/t/make-plugin-backward-compataible/191003/1 "2019-07-17T13:20:22Z")

</div>

Hi there,

So I created a Kibana plugin for version 7.0  
However, it turns out I will be using version 6.5.

What's the easiest way to make the plugin compatible with that version?  
I'm also using version 7 of the Elasticsearch JS client.

Regards,  
Dilshan

---

<div class="post-metadata">

**Author:** ![lukas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas/32/6812_2.png) [@lukas](https://discuss.elastic.co/u/lukas)\
**Post date:** [July 17, 2019, 11:57pm UTC](https://discuss.elastic.co/t/make-plugin-backward-compataible/191003/2 "2019-07-17T23:57:08Z")

</div>

What issues are you seeing when you try to load your plugin in 6.5?

---

<div class="post-metadata">

**Author:** ![dkelsen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dkelsen/32/46291_2.png) [@dkelsen](https://discuss.elastic.co/u/dkelsen)\
**Post date:** [July 30, 2019, 1:08pm UTC](https://discuss.elastic.co/t/make-plugin-backward-compataible/191003/3 "2019-07-30T13:08:20Z")

</div>

I get the following error:

 ![Capture](https://us1.discourse-cdn.com/elastic/original/3X/5/1/51d37c227313cf0b0441586e9f2ce14f7d9aa40e.png)

This error doesn't occur when I try to install it in version 7.0

Coincidentally, the error is happening with code (written in typescript) I've copied from the [EUI Github repository](https://github.com/elastic/eui).

When I try installing it again, it says `Plugin alerts already exists, please remove before installing a new version`.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 27, 2019, 1:08pm UTC](https://discuss.elastic.co/t/make-plugin-backward-compataible/191003/4 "2019-08-27T13:08:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
