# Manual run elasticsearch 5.4

**URL:** <https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981>\
**Category:** Elasticsearch\
**Created:** [May 8, 2017, 9:10pm UTC](https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981 "2017-05-08T21:10:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![rob1](https://avatars.discourse-cdn.com/v4/letter/r/e495f1/32.png) [@rob1](https://discuss.elastic.co/u/rob1)\
**Post date:** [May 8, 2017, 9:10pm UTC](https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981/1 "2017-05-08T21:10:29Z")

</div>

Hi

I'm trying to run elasticsearch 5,4 manually by entering (exact line created by `service elasticsearch start`):  
`/usr/bin/java -Xms200m -Xmx200m -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/usr/share/elasticsearch -cp /usr/share/elasticsearch/lib/* org.elasticsearch.bootstrap.Elasticsearch -d -p /var/run/elasticsearch/elasticsearch.pid -Edefault.path.logs=/var/log/elasticsearch -Edefault.path.data=/var/lib/elasticsearch -Edefault.path.conf=/etc/elasticsearch`

Unfortunately it generates error mesage:  
`Error: Could not find or load main class .usr.share.elasticsearch.lib.HdrHistogram-2.1.9.jar`

Above execution command with parameters is identical to this which is created by:  
`service elasticsearch start`

With previous elasticsearch 5.3.2 it worked fine.

Any ideas how to run it manually?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 9, 2017, 6:41am UTC](https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981/2 "2017-05-09T06:41:42Z")

</div>

How did you install ES?

---

<div class="post-metadata">

**Author:** ![rob1](https://avatars.discourse-cdn.com/v4/letter/r/e495f1/32.png) [@rob1](https://discuss.elastic.co/u/rob1)\
**Post date:** [May 9, 2017, 9:57am UTC](https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981/3 "2017-05-09T09:57:55Z")

</div>

I install it by just (ubuntu 14.04): `dpkg -i elasticsearch-5.4.0.deb`

After that `service elasticsearch start` works as expected but the same line executed manually generates error message:  
`Error: Could not find or load main class .usr.share.elasticsearch.lib.HdrHistogram-2.1.9.jar`

---

<div class="post-metadata">

**Author:** ![rob1](https://avatars.discourse-cdn.com/v4/letter/r/e495f1/32.png) [@rob1](https://discuss.elastic.co/u/rob1)\
**Post date:** [May 9, 2017, 12:49pm UTC](https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981/4 "2017-05-09T12:49:36Z")

</div>

Problem solved, it's about quotation marks around `-cp` parameter, proper command looks like:  
`/usr/bin/java -Xms200m -Xmx200m -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/usr/share/elasticsearch -cp "/usr/share/elasticsearch/lib/*" org.elasticsearch.bootstrap.Elasticsearch -d -p /var/run/elasticsearch/elasticsearch.pid -Edefault.path.logs=/var/log/elasticsearch -Edefault.path.data=/var/lib/elasticsearch -Edefault.path.conf=/etc/elasticsearch`

Thanks anyway.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 6, 2017, 1:00pm UTC](https://discuss.elastic.co/t/manual-run-elasticsearch-5-4/84981/5 "2017-06-06T13:00:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
