# \_map name exception with redmine elastic search plugin

**URL:** https://discuss.elastic.co/t/map-name-exception-with-redmine-elastic-search-plugin/150092
**Category:** Elasticsearch
**Created:** [September 26, 2018, 9:26pm UTC](https://discuss.elastic.co/t/map-name-exception-with-redmine-elastic-search-plugin/150092 "2018-09-26T21:26:59Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![gessel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gessel/32/35896_2.png) [@gessel](https://discuss.elastic.co/u/gessel)
#### Post date: [September 26, 2018, 9:26pm UTC](https://discuss.elastic.co/t/map-name-exception-with-redmine-elastic-search-plugin/150092/1 "2018-09-26T21:26:59Z")

</div>

I realize this is likely an issue with the [Redmine Elasticsearch plugin](https://github.com/Restream/redmine_elasticsearch) and likely requires an update from the author, but any advice would be much appreciated.

The error reported when executing a $ bundle exec rake redmine\_elasticsearch:reindex\_all RAILS\_ENV=production --trace is

```
snip
2018-09-26 14:17:31 -0700: < {"acknowledged":true,"shards_acknowledged":true,"index":"redmineapp_production"}
2018-09-26 14:17:31 -0700: PUT http://127.0.0.1:9200/redmineapp_production/_mapping/_doc [status:400, request:0.023s, query:N/A]
2018-09-26 14:17:31 -0700: > {"_doc":{"_parent":{"type":"parent_project"}}}
2018-09-26 14:17:31 -0700: < {"error":{"root_cause":[{"type":"invalid_type_name_exception","reason":"Document mapping type name can't start with '_', found: [_doc]"}],"type":"invalid_type_name_exception","reason":"Document mapping type name can't start with '_', found: [_doc]"},"status":400}
2018-09-26 14:17:31 -0700: [400] {"error":{"root_cause":[{"type":"invalid_type_name_exception","reason":"Document mapping type name can't start with '_', found: [_doc]"}],"type":"invalid_type_name_exception","reason":"Document mapping type name can't start with '_', found: [_doc]"},"status":400}
rake aborted!
Elasticsearch::Transport::Transport::Errors::BadRequest: [400] {"error":{"root_cause":[{"type":"invalid_type_name_exception","reason":"Document mapping type name can't start with '_', found: [_doc]"}],"type":"invalid_type_name_exception","reason":"Document mapping type name can't start with '_', found: [_doc]"},"status":400}
/usr/local/lib/ruby/gems/2.4/gems/elasticsearch-transport-6.1.0/lib/elasticsearch/transport/transport/base.rb:205:in `__raise_transport_error'
snip

```

elasticsearch5-5.6.8\_5  
rubygem-elasticsearch-6.1.0  
rubygem-elasticsearch-api-6.1.0  
rubygem-elasticsearch-transport-6.1.0

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 24, 2018, 9:27pm UTC](https://discuss.elastic.co/t/map-name-exception-with-redmine-elastic-search-plugin/150092/2 "2018-10-24T21:27:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
