# Mapper for \[@timestamp\] conflicts

**URL:** <https://discuss.elastic.co/t/mapper-for-timestamp-conflicts/76144>\
**Category:** Logstash\
**Created:** [February 23, 2017, 4:12am UTC](https://discuss.elastic.co/t/mapper-for-timestamp-conflicts/76144 "2017-02-23T04:12:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rsaeks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rsaeks/32/5068_2.png) [@rsaeks](https://discuss.elastic.co/u/rsaeks)\
**Post date:** [February 23, 2017, 4:12am UTC](https://discuss.elastic.co/t/mapper-for-timestamp-conflicts/76144/1 "2017-02-23T04:12:41Z")

</div>

After trying to track down why some data wasn't showing up, I found the following warning message in my logstash file:

[2017-02-22T21:34:23,198][WARN][logstash.outputs.elasticsearch] Failed action. {:status=\>400, :action=\>["index", {:\_id=\>nil, :\_index=\>"logstash-2017.02.23", :\_type=\>"cisco-wlc", :\_routing=\>nil}, 2017-02-23T03:34:23.184Z [log.d35.org](http://log.d35.org) Feb 22 21:34:22 [cisco-capwap-controller.d35.org](http://cisco-capwap-controller.d35.org) GCS-WLC-5508-01: \*dot1xMsgTask: Feb 22 21:34:22.587: %DOT1X-4-MAX\_EAPOL\_KEY\_RETRANS: 1x\_ptsm.c:509 Max EAPOL-key M5 retransmissions exceeded for client 10:9a:dd:a2:9a:45], :response=\>{"index"=\>{"\_index"=\>"logstash-2017.02.23", "\_type"=\>"cisco-wlc", "\_id"=\>"AVppCLbYuDat7D6I1xDm", "status"=\>400, "error"=\>{"type"=\>"illegal\_argument\_exception", "reason"=\>"Mapper for [@timestamp] conflicts with existing mapping in other types:\n[mapper [@timestamp] is used by multiple types. Set update\_all\_types to true to update [format] across all types.]"}}}}

It looks like the error is due to: Mapper for [@timestamp] conflicts with existing mapping in other types:\n[mapper [@timestamp] is used by multiple types. Set update\_all\_types to true to update [format] across all types.]

I looked at [https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-put-mapping.html#merging-conflicts](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-put-mapping.html#merging-conflicts) but am not able to figure out exactly what needs to be put in to fix the issue. All my indicies show @timestamp of type date.

Would anyone be able to share some tips for what I am missing?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 23, 2017, 4:12am UTC](https://discuss.elastic.co/t/mapper-for-timestamp-conflicts/76144/2 "2017-03-23T04:12:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
