# Mapping definition has unsupported parameters: \[norms : false\]

**URL:** <https://discuss.elastic.co/t/mapping-definition-has-unsupported-parameters-norms-false/290911>\
**Category:** Elasticsearch\
**Created:** [December 3, 2021, 3:28pm UTC](https://discuss.elastic.co/t/mapping-definition-has-unsupported-parameters-norms-false/290911 "2021-12-03T15:28:58Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![NLSVTN](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nlsvtn/32/84889_2.png) [@NLSVTN](https://discuss.elastic.co/u/NLSVTN)\
**Post date:** [December 3, 2021, 3:28pm UTC](https://discuss.elastic.co/t/mapping-definition-has-unsupported-parameters-norms-false/290911/1 "2021-12-03T15:28:58Z")

</div>

I am trying to disable **norms** in Elasticsearch 6.8 but getting the error:

> elasticsearch.exceptions.RequestError: TransportError(400, 'mapper\_parsing\_exception', 'Mapping definition for [AC] has unsupported parameters: [norms : false]'

Mapping looks like that:

{'AC': {'doc\_values': False, 'norms': False, 'type': 'integer'}, ...}

**doc\_values** can be disabled fine but **norms** - not.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 6, 2021, 1:50am UTC](https://discuss.elastic.co/t/mapping-definition-has-unsupported-parameters-norms-false/290911/2 "2021-12-06T01:50:58Z")

</div>

`norms` is not a supported parameter for integer fields - [Numeric datatypes | Elasticsearch Guide [6.8] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/6.8/number.html#number-params)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 3, 2022, 1:51am UTC](https://discuss.elastic.co/t/mapping-definition-has-unsupported-parameters-norms-false/290911/3 "2022-01-03T01:51:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
