# Marking url as dead. Last error: \[LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError\] Elasticsearch Unreachable

**URL:** <https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761>\
**Category:** Logstash\
**Created:** [January 3, 2019, 8:00am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761 "2019-01-03T08:00:50Z")\
**Posts on this page:** 11\
**Page:** 2

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 4, 2019, 7:15am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/21 "2019-01-04T07:15:17Z")

</div>

What is the exact error you are getting with this config?

---

<div class="post-metadata">

**Author:** ![arun5635](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@arun5635](https://discuss.elastic.co/u/arun5635)\
**Post date:** [January 4, 2019, 10:04am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/22 "2019-01-04T10:04:11Z")

</div>

I fixed it , it was because of instance it was crashing. but problem still there with elastic search output plugin. I am using two logstash server , elastic search out plugin is working fine in other logstash server. this is the error i am getting

[2019-01-04T10:03:16,040][ERROR][logstash.outputs.elasticsearch] Attempted to send a bulk request to elasticsearch, but no there are no living connections in the connection pool. Perhaps Elasticsearch is unreachable or down? {:error\_message=\>"No Available connections", :class=\>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::NoConnectionAvailableError", :will\_retry\_in\_seconds=\>4}

---

<div class="post-metadata">

**Author:** ![arun5635](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@arun5635](https://discuss.elastic.co/u/arun5635)\
**Post date:** [January 4, 2019, 10:06am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/23 "2019-01-04T10:06:17Z")

</div>

this is the conf file of logstash server which is working file

input {  
s3 {  
bucket =\> "docsapp-alb-accesslogs"  
prefix =\> "askadoc"  
region =\> "us-west-2"  
type =\> "elblogs"  
codec =\> "plain"  
delete =\> "true"  
secret\_access\_key =\> ""  
access\_key\_id =\> ""  
}  
}

filter {  
grok {  
match =\> {"message" =\> '%{TIMESTAMP\_ISO8601:timestamp} %{NOTSPACE:elb\_name} %{IP:elb\_client\_ip}:%{INT:elb\_client\_port:int} (?:%{IP:elb\_backend\_ip}:%{NUMBER:elb\_backend\_port:int}|-) %{NUMBER:request\_processing\_time:float} %{NUMBER:backend\_processing\_time:float} %{NUMBER:response\_processing\_time:float} (?:%{INT:elb\_status\_code:int}|-) (?:%{INT:backend\_status\_code:int}|-) %{INT:elb\_received\_bytes:int} %{INT:elb\_sent\_bytes:int} "(?:%{GREEDYDATA:elb\_request}|-)" "(?:%{GREEDYDATA:userAgent}|-)" %{NOTSPACE:elb\_sslcipher} %{NOTSPACE:elb\_sslprotocol}'}  
}

```
   mutate {
             convert => {
                        "elb_status_code" => "integer"
                        "backend_status_code" => "integer"
                       }

```

}  
}

output {  
file{  
path =\> "/var/log/logstash/askadoc-accesslog-%{+YYYY.MM.dd}.log"  
}

```
    elasticsearch {
		hosts => "http://search-askadocbacked-logs-6d **********.us-west-2.es.amazonaws.com:80"
		index => "askadoc-accesslog-%{+YYYY.MM.dd}"
	      }

```

}

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 4, 2019, 10:06am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/24 "2019-01-04T10:06:30Z")

</div>

What is different between the config that is working and the one that is not?

---

<div class="post-metadata">

**Author:** ![arun5635](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@arun5635](https://discuss.elastic.co/u/arun5635)\
**Post date:** [January 4, 2019, 10:07am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/25 "2019-01-04T10:07:40Z")

</div>

only the bucket and aws ES endpoint url are different

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 4, 2019, 10:08am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/26 "2019-01-04T10:08:46Z")

</div>

Can you curl both ES endpoints successfully from the machine where Logstash is running?

---

<div class="post-metadata">

**Author:** ![arun5635](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@arun5635](https://discuss.elastic.co/u/arun5635)\
**Post date:** [January 4, 2019, 10:10am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/27 "2019-01-04T10:10:03Z")

</div>

yes both are working

---

<div class="post-metadata">

**Author:** ![arun5635](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@arun5635](https://discuss.elastic.co/u/arun5635)\
**Post date:** [January 4, 2019, 10:10am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/28 "2019-01-04T10:10:39Z")

</div>

[root@ip-172-31-40-86 conf.d]# curl https://search-askadocbacked-logs-.us-west-2.es.amazonaws.com  
{  
"name" : "vu0erEX",  
"cluster\_name" : "547208114500:askadocbacked-logs",  
"cluster\_uuid" : "FhXphpj7ROm5US4E3WEiIA",  
"version" : {  
"number" : "6.3.1",  
"build\_flavor" : "oss",  
"build\_type" : "zip",  
"build\_hash" : "eb782d0",  
"build\_date" : "2018-09-11T14:05:25.216906Z",  
"build\_snapshot" : false,  
"lucene\_version" : "7.3.1",  
"minimum\_wire\_compatibility\_version" : "5.6.0",  
"minimum\_index\_compatibility\_version" : "5.0.0"  
},  
"tagline" : "You Know, for Search"  
}  
[root@ip-172-31-40-86 conf.d]# curl https://search-mb-production-app-.us-west-2.es.amazonaws.com  
{  
"name" : "9LExCRY",  
"cluster\_name" : "547208114500:mb-production-app",  
"cluster\_uuid" : "DXz6TOQqSVed2ygweUu2EA",  
"version" : {  
"number" : "6.3.1",  
"build\_flavor" : "oss",  
"build\_type" : "zip",  
"build\_hash" : "eb782d0",  
"build\_date" : "2018-09-11T14:05:25.216906Z",  
"build\_snapshot" : false,  
"lucene\_version" : "7.3.1",  
"minimum\_wire\_compatibility\_version" : "5.6.0",  
"minimum\_index\_compatibility\_version" : "5.0.0"  
},  
"tagline" : "You Know, for Search"

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 4, 2019, 10:13am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/29 "2019-01-04T10:13:00Z")

</div>

How do you know the issue is with the output and not with the input?

Those clusters appear to be open to the internet, which means anyone could gain access to them and read/add/alter/delete data. **I would recommend that you secure them immediately.**

Relying on the URL being "secret" is not protecting you against port scans.

---

<div class="post-metadata">

**Author:** ![arun5635](https://avatars.discourse-cdn.com/v4/letter/a/c89c15/32.png) [@arun5635](https://discuss.elastic.co/u/arun5635)\
**Post date:** [January 4, 2019, 10:19am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/30 "2019-01-04T10:19:44Z")

</div>

if the issue is with input means it wont register the bucket itself but it showing error as ERROR[logstash.outputs.elasticsearch].

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 1, 2019, 10:19am UTC](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761/31 "2019-02-01T10:19:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

[Previous page](https://discuss.elastic.co/t/marking-url-as-dead-last-error-logstash-hostunreachableerror-elasticsearch-unreachable/162761.md?page=1)
