# Marvel.agent.exporter.http could not connect to any configurd elasticsearch instances

**URL:** <https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring\
**Created:** [December 8, 2016, 9:34am UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414 "2016-12-08T09:34:54Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Netanel\_Malka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/netanel_malka/32/47520_2.png) [@Netanel\_Malka](https://discuss.elastic.co/u/Netanel_Malka)\
**Post date:** [December 8, 2016, 9:34am UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414/1 "2016-12-08T09:34:54Z")

</div>

I have elasticsearch prod cluster of two nodes(es-prod).  
I created another cluster for monitoring those elastic nodes(es-mon).  
Thus, I configured the marvel agent for monitoring cluster as explained here:  
[monitoring-cluster](https://www.elastic.co/guide/en/marvel/current/installing-marvel.html#monitoring-cluster)

But I still got this ERROR message on the es-prod nodes.  
In kibana, marvel calims that there is no data.  
Also, there is no .marvel indices on the es-mon elastic.  
The main error message:  
marvel.agent.exporter.http could not connect to any configurd elasticsearch instances[\<instance\_name\>]  
I be able to connect from the es-prod to the es-mon elastic.  
But, somehow marvel failed to connect...  
version details:  
marvel- 2.4.1  
elasticsearch - 2.4.1  
kibana - 4.6.2  
Thanks..

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [December 9, 2016, 5:24pm UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414/2 "2016-12-09T17:24:45Z")

</div>

Are you sure that whatever hostname and port you're using on the `es-prod` nodes can actually be accessed from those machines? If you've got a firewall or something in between `es-prod` and `es-mon`, perhaps it's blocking that communication.

EDIT: Also, are you using Security? If so, have you added the `auth` defaults to your config file?

---

<div class="post-metadata">

**Author:** ![Netanel\_Malka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/netanel_malka/32/47520_2.png) [@Netanel\_Malka](https://discuss.elastic.co/u/Netanel_Malka)\
**Post date:** [December 11, 2016, 9:00am UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414/3 "2016-12-11T09:00:00Z")

</div>

Yes. I succeeded to connect from es-mon to es-prod and from es-prod to es-mon.  
Also, I don't use Security yet...  
I tried to remove marvel and set up again, but it doesn't help.  
Thanks a lot.

---

<div class="post-metadata">

**Author:** ![bohyun](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bohyun/32/10087_2.png) [@bohyun](https://discuss.elastic.co/u/bohyun)\
**Post date:** [December 12, 2016, 5:31pm UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414/4 "2016-12-12T17:31:50Z")

</div>

Hi @Netanel_Malka

based on the error, it seems like the monitoring cluster, es-mon, is not reachable. Could you make sure that your es-mon cluster is running?

Also, could you share your config settings(elasticsearch.yml) for both your es-mon and es-prod clusters?

Thanks,  
Bohyun

---

<div class="post-metadata">

**Author:** ![Netanel\_Malka](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/netanel_malka/32/47520_2.png) [@Netanel\_Malka](https://discuss.elastic.co/u/Netanel_Malka)\
**Post date:** [December 13, 2016, 7:51am UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414/5 "2016-12-13T07:51:31Z")

</div>

I don't know what happened but today I found that .marvel indices created in the es-mon,  
In the kibana.yml file, I set the `elasticsearch_url: es-prod` instead of es-mon.  
Now it works.  
Thanks a lot for your quick responses 😃  
Netanel

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2017, 7:51am UTC](https://discuss.elastic.co/t/marvel-agent-exporter-http-could-not-connect-to-any-configurd-elasticsearch-instances/68414/6 "2017-01-10T07:51:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
