# Marvel: Error 400 Bad Request: Cannot assign to read only property 'type' of green

**URL:** <https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-monitoring\
**Created:** [October 10, 2016, 6:57pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658 "2016-10-10T18:57:07Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![indokarthi](https://avatars.discourse-cdn.com/v4/letter/i/ee59a6/32.png) [@indokarthi](https://discuss.elastic.co/u/indokarthi)\
**Post date:** [October 10, 2016, 6:57pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/1 "2016-10-10T18:57:07Z")

</div>

![](https://us1.discourse-cdn.com/elastic/original/2X/f/f93f2e9422b0b3b8815a72c8b96bbdcd85996e7c.JPG)

Has anyone facing this issue ?  
It happens as soon as I hit [http://localhost:5601/app/marvel](http://localhost:5601/app/marvel).

Here are details of our cluster.  
ES - 2.3.2  
Marvel agent - 2.3.2  
Kibana - 4.5  
Marvel - 2.3.2

Marvel is pointing to separate one node monitoring cluster.

Found this in the log:  
{"type":"response","@timestamp":"2016-10-10T18:58:29+00:00","tags":,"pid":15962,"method":"post","statusCode":400,"req":{"url":"/api/marvel/v1/clusters/3ut\_McNuTI2om20lth9Cuw","method":"post","headers":{"host":":5601","connection":"keep-alive","content-length":"200","accept":"application/json, text/plain, _/_","origin":"http://:5601","kbn-version":"4.5.0","user-agent":"Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36","content-type":"application/json;charset=UTF-8","referer":"http://:5601/app/marvel","accept-encoding":"gzip, deflate","accept-language":"en-US,en;q=0.8,ta;q=0.6"},"remoteAddress":"","userAgent":"","referer":"http://:5601/app/marvel"},"res":{"statusCode":400,"responseTime":224,"contentLength":9},"message":"POST /api/marvel/v1/clusters/3ut\_McNuTI2om20lth9Cuw 400 224ms - 9.0B"}

---

<div class="post-metadata">

**Author:** ![pickypg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pickypg/32/62409_2.png) [@pickypg](https://discuss.elastic.co/u/pickypg)\
**Post date:** [October 10, 2016, 7:39pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/2 "2016-10-10T19:39:44Z")

</div>

Hi,

I have not seen this issue before. However, from your loggered message, I did notice that the Kibana host seems to be set improperly?

```auto
"origin":"http://:5601"

```

I'm not so sure that that's the cause, but it's probably not helping. Any chance that you could show your Kibana configuration?

Thanks,  
Chris

---

<div class="post-metadata">

**Author:** ![indokarthi](https://avatars.discourse-cdn.com/v4/letter/i/ee59a6/32.png) [@indokarthi](https://discuss.elastic.co/u/indokarthi)\
**Post date:** [October 10, 2016, 8:22pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/3 "2016-10-10T20:22:43Z")

</div>

I am only setting this  
elasticsearch.url: [http://localhost:9290](http://localhost:9290)

---

<div class="post-metadata">

**Author:** ![pickypg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pickypg/32/62409_2.png) [@pickypg](https://discuss.elastic.co/u/pickypg)\
**Post date:** [October 10, 2016, 8:24pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/4 "2016-10-10T20:24:29Z")

</div>

In your Kibana configuration (`kibana.yml`), can you change this just to see what happens?

```auto
server.host: 127.0.0.1

```

Then try again?

---

<div class="post-metadata">

**Author:** ![indokarthi](https://avatars.discourse-cdn.com/v4/letter/i/ee59a6/32.png) [@indokarthi](https://discuss.elastic.co/u/indokarthi)\
**Post date:** [October 10, 2016, 8:37pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/5 "2016-10-10T20:37:34Z")

</div>

The UI is not showing up after this change. Also i have multiple clusters working fine with the similar configuration in kibana. This is happening only on one cluster

---

<div class="post-metadata">

**Author:** ![indokarthi](https://avatars.discourse-cdn.com/v4/letter/i/ee59a6/32.png) [@indokarthi](https://discuss.elastic.co/u/indokarthi)\
**Post date:** [October 11, 2016, 2:43pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/6 "2016-10-11T14:43:22Z")

</div>

i just realized the ip's are blanked out in the post. But the log shows actual ip of kibana server.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:41pm UTC](https://discuss.elastic.co/t/marvel-error-400-bad-request-cannot-assign-to-read-only-property-type-of-green/62658/7 "2017-07-06T13:41:53Z")

</div>


