# Marvel Problem with some dashboards

**URL:** <https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [May 26, 2015, 3:17pm UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324 "2015-05-26T15:17:15Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![ChrisMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrismark/32/400_2.png) [@ChrisMark](https://discuss.elastic.co/u/ChrisMark)\
**Post date:** [May 26, 2015, 3:17pm UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324/1 "2015-05-26T15:17:15Z")

</div>

Ηello guys,

i had my marvel page working fine some hours ago, but now i have a problem. The problem is that Overview page as well as Shard Allocation page cannot be loaded. In overview page i take empty diagramms and in shard allocation i get **_"Error The connection to Elasticsearch returned an error. Check your Elasticsearch instance."_**

The thing is that i can load cluster pulse Node and Index statistics pages and of course elasticsearch is working properly. What the problem may is?  
Thanx!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 27, 2015, 12:20am UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324/2 "2015-05-27T00:20:22Z")

</div>

Is there anything in your Elasticsearch logs that might point to a problem?

---

<div class="post-metadata">

**Author:** ![ChrisMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrismark/32/400_2.png) [@ChrisMark](https://discuss.elastic.co/u/ChrisMark)\
**Post date:** [May 27, 2015, 9:25am UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324/3 "2015-05-27T09:25:43Z")

</div>

Yes, each time i refresh the page the following log occurs:

ubuntu@logstashganglia:/var/log/elasticsearch$ tail cslabES.log  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.search.SearchParseException: [.marvel-2015.05.27][0]: from[-1],size[1]: Parse Failure [No mapping found for [@timestamp] in order to sort on]  
at org.elasticsearch.search.sort.SortParseElement.addSortField(SortParseElement.java:210)  
at org.elasticsearch.search.sort.SortParseElement.addCompoundSortField(SortParseElement.java:184)  
at org.elasticsearch.search.sort.SortParseElement.parse(SortParseElement.java:96)  
at org.elasticsearch.search.SearchService.parseSource(SearchService.java:671)  
... 9 more  
[2015-05-27 09:25:41,551][DEBUG][action.search.type] [MasterNode] All shards failed for phase: [query\_fetch]

---

<div class="post-metadata">

**Author:** ![ChrisMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrismark/32/400_2.png) [@ChrisMark](https://discuss.elastic.co/u/ChrisMark)\
**Post date:** [May 27, 2015, 11:06am UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324/4 "2015-05-27T11:06:37Z")

</div>

I think the problem occured when the master node changed from one physical node to onather one. I "played" a lot by changing who would be the master node and now overview works fine. However i still cannot load shard alocation page. The log is the same:  
[2015-05-27 11:04:19,253][DEBUG][action.search.type] [ES8] All shards failed for phase: [query\_fetch]

---

<div class="post-metadata">

**Author:** ![Jonathan\_Evain](https://avatars.discourse-cdn.com/v4/letter/j/8edcca/32.png) [@Jonathan\_Evain](https://discuss.elastic.co/u/Jonathan_Evain)\
**Post date:** [December 16, 2015, 1:28pm UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324/5 "2015-12-16T13:28:36Z")

</div>

It might be obvious but, be sure that Marvel plugin is installed on each nodes (or ES instances).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:46pm UTC](https://discuss.elastic.co/t/marvel-problem-with-some-dashboards/1324/6 "2017-07-06T13:46:01Z")

</div>


