# Master Node cant connect

**URL:** <https://discuss.elastic.co/t/master-node-cant-connect/345899>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-security\
**Created:** [October 27, 2023, 9:27am UTC](https://discuss.elastic.co/t/master-node-cant-connect/345899 "2023-10-27T09:27:02Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nerd0](https://avatars.discourse-cdn.com/v4/letter/n/edb3f5/32.png) [@Nerd0](https://discuss.elastic.co/u/Nerd0)\
**Post date:** [October 27, 2023, 9:27am UTC](https://discuss.elastic.co/t/master-node-cant-connect/345899/1 "2023-10-27T09:27:02Z")

</div>

Hi, I have a problem caused by: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: Path does not chain with any of the trust anchors

I configured 3 node clusters using a token, all 3 nodes worked, however, during tests and turning off node 1, a discover error occurred, after adding the discover host, i.e. the addresses of the remaining nodes, the error changed to the one with the certificate. Currently, clutser after \_cat/nodes shows 2 nodes, but node 1 cannot connect. due to certificate error

---

<div class="post-metadata">

**Author:** ![TimV](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timv/32/13162_2.png) [@TimV](https://discuss.elastic.co/u/TimV)\
**Post date:** [October 29, 2023, 11:11am UTC](https://discuss.elastic.co/t/master-node-cant-connect/345899/2 "2023-10-29T11:11:27Z")

</div>

Can you provide logs and/or configuration?

It's hard to diagnose TLS trust issues without a bit more detail.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 26, 2023, 11:11am UTC](https://discuss.elastic.co/t/master-node-cant-connect/345899/3 "2023-11-26T11:11:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
