# Master not discovered exception

**URL:** <https://discuss.elastic.co/t/master-not-discovered-exception/81923>\
**Category:** Elasticsearch\
**Created:** [April 11, 2017, 7:08am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923 "2017-04-11T07:08:53Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Emrah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/emrah/32/17657_2.png) [@Emrah](https://discuss.elastic.co/u/Emrah)\
**Post date:** [April 11, 2017, 7:08am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/1 "2017-04-11T07:08:53Z")

</div>

Hi there,

We had 4 nodes and added fifth one yesterday. We were expecting to find master automatically but got master\_not\_discovered\_exception. Furthermore other 4 nodes act like there is no fifth node. All of nodes have same configuration.

```
     discovery: {
    zen: {
    ping: {
    unicast: {
    hosts: [
    "x.x.x.1",
    "x.x.x.2",
    "x.x.x.3",
    "x.x.x.4",
    "x.x.x.5"
    ]
    }
    }
    }
    },
    client: {
    type: "node"
    },
    http: {
    type: {
    default: "netty4"
    },
    port: "9200"
    },
    transport: {
    type: {
    default: "netty4"
    }
    }
```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 11, 2017, 7:39am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/2 "2017-04-11T07:39:10Z")

</div>

What's the error?  
What version?

---

<div class="post-metadata">

**Author:** ![Emrah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/emrah/32/17657_2.png) [@Emrah](https://discuss.elastic.co/u/Emrah)\
**Post date:** [April 11, 2017, 7:55am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/3 "2017-04-11T07:55:14Z")

</div>

Version 5.2.2  
telnet to master ok. ping ok. But got the error below when i try to search on index

![](https://us1.discourse-cdn.com/elastic/original/3X/6/2/62dc90bdc6f74abb74d0d2d06e52413b9755ab1b.png)

And when i check for the node information on master here i got  
 ![](https://us1.discourse-cdn.com/elastic/original/3X/8/d/8dbdf8de7d3177149efd61ef300d9fa444759f0c.png)

By the way all 4 nodes have this configuration  
 ![](https://us1.discourse-cdn.com/elastic/original/3X/a/d/ad4c8cc9014799e044abb41a648d56a699ce56d4.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 11, 2017, 9:55am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/4 "2017-04-11T09:55:27Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them.

---

<div class="post-metadata">

**Author:** ![Emrah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/emrah/32/17657_2.png) [@Emrah](https://discuss.elastic.co/u/Emrah)\
**Post date:** [April 11, 2017, 11:22am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/5 "2017-04-11T11:22:17Z")

</div>

Ok. Sorry about that Mark, Here is the answer without pictures.  
Version 5.2.2  
telnet to master ok. ping ok. But got the error below when i try to search on index

```
{
  error: {
    root_cause: [
      {
        type: "master_not_discovered_exception",
        reason: null
      }
    ],
    type: "master_not_discovered_exception",
    reason: null
  },
  status: 503
}

```

And when i check for the node information on master here i got

```
  {
    _nodes: {
      total: 4,
      successful: 4,
      failed: 0
    }
  }

```

By the way all 4 nodes have this configuration

```
 roles: [
    "master",
    "data",
   "ingest"
 ],

```

And the exception in the log

[2017-04-12T12:05:14,155][INFO][o.e.d.z.ZenDiscovery] [node-5] failed to send join request to master [{node-1}{rzzzzzzzzzzzzzzzzzzzzzzzzzz}{3aaaaaaaaaaaaaaaaaaaaa}{y.y.y.y}{y.y.y.y:9300}], reason [RemoteTransportException[[node-1][y.y.y.y:9300][internal:discovery/zen/join]]; nested: ConnectTransportException[[node-5][x.x.x.x:9300] connect\_timeout[30s]]; nested: IOException[Connectiontimed out: no further information: x.x.x.x/x.x.x.x:9300];]

---

<div class="post-metadata">

**Author:** ![tomer](https://avatars.discourse-cdn.com/v4/letter/t/41988e/32.png) [@tomer](https://discuss.elastic.co/u/tomer)\
**Post date:** [April 23, 2017, 11:57am UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/7 "2017-04-23T11:57:12Z")

</div>

> [@Emrah](#):
>
> fifth one yesterday. We were expecting to find master automatically but got master\_not\_discovered\_exception. Furthermore other 4 nodes act like there is no fifth node.

Hi if you found an answer I will be happy to hear 🙂

---

<div class="post-metadata">

**Author:** ![Emrah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/emrah/32/17657_2.png) [@Emrah](https://discuss.elastic.co/u/Emrah)\
**Post date:** [April 23, 2017, 1:14pm UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/8 "2017-04-23T13:14:16Z")

</div>

Hey Tomer,

It was because of Windows firewall. I added 9300 port to firewall on fifth node and its gone live.

---

<div class="post-metadata">

**Author:** ![techpanga](https://avatars.discourse-cdn.com/v4/letter/t/3ab097/32.png) [@techpanga](https://discuss.elastic.co/u/techpanga)\
**Post date:** [May 20, 2017, 8:16pm UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/9 "2017-05-20T20:16:31Z")

</div>

Hi

My case is similar but no issues with firewall. Here are details...

> [@ElasticSearch 5.4 Nodes unable to join cluster - Troubleshooting](https://discuss.elastic.co/t/elasticsearch-5-4-nodes-unable-to-join-cluster-troubleshooting/86536):
>
> Hi There, We are running into some issues post upgrade from 2.3.x to 5.4. OS : RHEL 7 Java : JDK1.8.0\_111 Server (VM) #1: node.name: node-1 network.host: xxx.xxx.197.14 cluster.name: dsinke3 node.master: true node.data: true path.data: /elkstore/elasticsearch path.logs: /elkstore/logs bootstrap.memory\_lock: true discovery.zen.ping.unicast.hosts: ["xxx.xxx.197.14:9200", "xxx.xxx.197.15:9200", "xxx.xxx.197.16:9200", "xxx.xxx.197.17:9200", "xxx.xxx.197.18:9200"] discovery.zen.minimum\_master\_n…

-Regards, dp

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 17, 2017, 8:16pm UTC](https://discuss.elastic.co/t/master-not-discovered-exception/81923/10 "2017-06-17T20:16:50Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
