# maxConcurrentShardRequests

**URL:** <https://discuss.elastic.co/t/maxconcurrentshardrequests/161602>\
**Category:** Kibana\
**Created:** [December 19, 2018, 11:04pm UTC](https://discuss.elastic.co/t/maxconcurrentshardrequests/161602 "2018-12-19T23:04:42Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ram\_Ibaset](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ram_ibaset/32/27747_2.png) [@Ram\_Ibaset](https://discuss.elastic.co/u/Ram_Ibaset)\
**Post date:** [December 19, 2018, 11:04pm UTC](https://discuss.elastic.co/t/maxconcurrentshardrequests/161602/1 "2018-12-19T23:04:43Z")

</div>

I am running into this problem and have spent days trying to find a solution and no luck.  
I am on ELK stack 6.5.3 running in docker and docker swarm cluster

It was working fine with 6.3.0 for months and after I upgraded it kibana does not come up. I am seeing the following error in the logs:

```
    {"type":"error","@timestamp":"2018-12-19T22:32:17Z","tags":["warning","stats-collection"],"pid":1,"level":"error","error":{"message"
:"[illegal_argument_exception] maxConcurrentShardRequests must be >= 1","name":"Error","stack":"[illegal_argument_exception] maxConcurrentShardRequests must be >= 1 :: {\"path\":\"/.reporting-*/_search\",\"query\":{\"fi
lter_path\":\"hits.total,aggregations.jobTypes.buckets,aggregations.objectTypes.buckets,aggregations.layoutTypes.buckets,aggregations.statusTypes.buckets\"},\"body\":\"{\\\"size\\\":0,\\\"aggs\\\":{\\\"jobTypes\\\":{\\\
"terms\\\":{\\\"field\\\":\\\"jobtype\\\",\\\"size\\\":2}},\\\"objectTypes\\\":{\\\"terms\\\":{\\\"field\\\":\\\"meta.objectType.keyword\\\",\\\"size\\\":3}},\\\"layoutTypes\\\":{\\\"terms\\\":{\\\"field\\\":\\\"meta.la
yout.keyword\\\",\\\"size\\\":3}},\\\"statusTypes\\\":{\\\"terms\\\":{\\\"field\\\":\\\"status\\\",\\\"size\\\":4}}}}\",\"statusCode\":400,\"response\":\"{\\\"error\\\":{\\\"root_cause\\\":[{\\\"type\\\":\\\"illegal_arg
ument_exception\\\",\\\"reason\\\":\\\"maxConcurrentShardRequests must be >= 1\\\"}],\\\"type\\\":\\\"illegal_argument_exception\\\",\\\"reason\\\":\\\"maxConcurrentShardRequests must be >= 1\\\"},\\\"status\\\":400}\"}
\n at respond (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:308:15)\n at checkRespForFailure (/usr/share/kibana/node_modules/elasticsearch/src/lib/transport.js:267:7)\n at HttpConnector.<an
onymous> (/usr/share/kibana/node_modules/elasticsearch/src/lib/connectors/http.js:165:7)\n at IncomingMessage.wrapper (/usr/share/kibana/node_modules/elasticsearch/node_modules/lodash/lodash.js:4949:19)\n at emitN
one (events.js:111:20)\n at IncomingMessage.emit (events.js:208:7)\n at endReadableNT (_stream_readable.js:1064:12)\n at _combinedTickCallback (internal/process/next_tick.js:139:11)\n at process._tickCallbac
k (internal/process/next_tick.js:181:9)"},"message":"[illegal_argument_exception] maxConcurrentShardRequests must be >= 1"}

```

I tried deleting the .kibana index and restarting the stack to no success.

---

<div class="post-metadata">

**Author:** ![lukas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas/32/6812_2.png) [@lukas](https://discuss.elastic.co/u/lukas)\
**Post date:** [December 20, 2018, 6:33pm UTC](https://discuss.elastic.co/t/maxconcurrentshardrequests/161602/2 "2018-12-20T18:33:51Z")

</div>

Looks like it may be similar to what this user experienced: [https://github.com/elastic/kibana/issues/16903](https://github.com/elastic/kibana/issues/16903)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 17, 2019, 6:33pm UTC](https://discuss.elastic.co/t/maxconcurrentshardrequests/161602/3 "2019-01-17T18:33:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
