# Memcached filter plugin issues

**URL:** <https://discuss.elastic.co/t/memcached-filter-plugin-issues/254095>\
**Category:** Logstash\
**Created:** [November 3, 2020, 3:48am UTC](https://discuss.elastic.co/t/memcached-filter-plugin-issues/254095 "2020-11-03T03:48:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![aleksf](https://avatars.discourse-cdn.com/v4/letter/a/c67d28/32.png) [@aleksf](https://discuss.elastic.co/u/aleksf)\
**Post date:** [November 3, 2020, 3:48am UTC](https://discuss.elastic.co/t/memcached-filter-plugin-issues/254095/1 "2020-11-03T03:48:06Z")

</div>

I was hoping this was fixed in [https://github.com/logstash-plugins/logstash-filter-memcached/pull/25](https://github.com/logstash-plugins/logstash-filter-memcached/pull/25) with the plugin release v1.1.0

Related issue was already raised in [Catch Memcached Filter exceptions](https://discuss.elastic.co/t/catch-memcached-filter-exceptions/226432) but this thread is closed so I am crating a new one.

Doing a simple test starting LS with memcached host unavailable. Getting message below:

```auto
[2020-11-03T03:04:23,322][ERROR][logstash.filters.memcached][sysmon_servers] failed to connect to memcached {:hosts=>["memcached:11211"], :options=>{:expires_in=>0}, :message=>"No server available"}
[2020-11-03T03:04:23,321][ERROR][logstash.filters.memcached][security_servers] failed to connect to memcached {:hosts=>["memcached:11211"], :options=>{:expires_in=>1800}, :message=>"No server available"}
[2020-11-03T03:04:23,346][ERROR][logstash.agent] Failed to execute action {:id=>:sysmon_servers, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<sysmon_servers>, action_result: false", :backtrace=>nil}
[2020-11-03T03:04:23,348][ERROR][logstash.agent] Failed to execute action {:id=>:security_servers, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<security_servers>, action_result: false", :backtrace=>nil}

[2020-11-03T03:28:06,823][WARN][org.logstash.plugins.pipeline.PipelineBus][distributor][6360b3d362cbbe9487b6ad8170404b906cf2f481c1aab51aa68c344b8b1ed2aa] Attempted to send event to 'security_servers' but that address was unavailable. Maybe the destination pipeline is down or stopping? Will Retry.
[2020-11-03T03:28:07,824][WARN][org.logstash.plugins.pipeline.PipelineBus][distributor][6360b3d362cbbe9487b6ad8170404b906cf2f481c1aab51aa68c344b8b1ed2aa] Attempted to send event to 'security_servers' but that address was unavailable. Maybe the destination pipeline is down or stopping? Will Retry.

```

Manually starting memcached service. Despite memcached is now available pipelines never recover until I manually restart Logstash, which is not ideal. Did PR mean to fix described behaviour? Is there possibly a way to handle it better?

TA  
A

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 1, 2020, 3:48am UTC](https://discuss.elastic.co/t/memcached-filter-plugin-issues/254095/2 "2020-12-01T03:48:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
