# Merge\_policy not in settings

**URL:** https://discuss.elastic.co/t/merge-policy-not-in-settings/5000
**Category:** Elasticsearch
**Created:** [July 29, 2011, 3:24pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000 "2011-07-29T15:24:41Z")
**Posts on this page:** 18
**Page:** 1

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [July 29, 2011, 3:24pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/1 "2011-07-29T15:24:41Z")

</div>

Hi

If I update my merge\_policy settings and then later try to retrieve the  
settings with the code below, merge\_policy does not appear in the result  
array. This is the case since ES 0.17.0.

curl -XGET '[http://localhost:9200/test/\_settings](http://localhost:9200/test/_settings)'

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [July 29, 2011, 6:36pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/2 "2011-07-29T18:36:34Z")

</div>

Can you gist an example of what you do exactly? You can't change the merge  
policy on an open index, only on a closed one.

On Fri, Jul 29, 2011 at 6:24 PM, Nicolas Ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> Hi
> 
> If I update my merge\_policy settings and then later try to retrieve the  
> settings with the code below, merge\_policy does not appear in the result  
> array. This is the case since ES 0.17.0.
> 
> curl -XGET '[http://localhost:9200/test/\_settings](http://localhost:9200/test/_settings)'

---

<div class="post-metadata">

### Author: ![Nicolas\_Ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nicolas_ruflin/32/3116_2.png) [@Nicolas\_Ruflin](https://discuss.elastic.co/u/Nicolas_Ruflin)
#### Post date: [July 29, 2011, 8:36pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/3 "2011-07-29T20:36:46Z")

</div>

## This probably explains the problem. I will try it with a closed index tomorrow. I tried to do it on an open index. Did this work on 0.16.\* or did it only "seem" to work?

[useKit.com](http://useKit.com)

> **[Xodoa](https://www.xodoa.com/)**

> **[Blog by Nicolas Ruflin](https://www.ruflin.com/)**
>
> Blog by Nicolas Ruflin

On 29.07.2011, at 20:36, Shay Banon wrote:

> Can you gist an example of what you do exactly? You can't change the merge policy on an open index, only on a closed one.
> 
> On Fri, Jul 29, 2011 at 6:24 PM, Nicolas Ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:  
> Hi
> 
> If I update my merge\_policy settings and then later try to retrieve the settings with the code below, merge\_policy does not appear in the result array. This is the case since ES 0.17.0.
> 
> curl -XGET '[http://localhost:9200/test/\_settings](http://localhost:9200/test/_settings)'

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [July 29, 2011, 10:29pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/4 "2011-07-29T22:29:20Z")

</div>

Seem to work 🙂

On Fri, Jul 29, 2011 at 11:36 PM, Nicolas Ruflin [mail@ruflin.com](mailto:mail@ruflin.com) wrote:

> ## This probably explains the problem. I will try it with a closed index tomorrow. I tried to do it on an open index. Did this work on 0.16.\* or did it only "seem" to work?
> 
> [useKit.com](http://useKit.com)  
> [Xodoa.com](http://Xodoa.com) [http://xodoa.com/](http://xodoa.com/)  
> [Ruflin.com](http://Ruflin.com) [http://ruflin.com](http://ruflin.com)
> 
> On 29.07.2011, at 20:36, Shay Banon wrote:
> 
> Can you gist an example of what you do exactly? You can't change the merge  
> policy on an open index, only on a closed one.
> 
> On Fri, Jul 29, 2011 at 6:24 PM, Nicolas Ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:
> 
> > Hi
> > 
> > If I update my merge\_policy settings and then later try to retrieve the  
> > settings with the code below, merge\_policy does not appear in the result  
> > array. This is the case since ES 0.17.0.
> > 
> > curl -XGET '[http://localhost:9200/test/\_settings](http://localhost:9200/test/_settings)'

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [July 30, 2011, 10:22am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/5 "2011-07-30T10:22:24Z")

</div>

Ok, closing the index solved the problem. This also explains the outcome of  
my performance tests under 0.16.\* 😉

For which other settings the index has to be closed first?

Thanks for your help.

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [July 30, 2011, 11:44am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/6 "2011-07-30T11:44:42Z")

</div>

The realtime settings are listed in the update settings API:  
[Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/reference/api/admin-indices-update-settings.html).  
Also, update settings will log settings that have not been applied.

On Sat, Jul 30, 2011 at 1:22 PM, ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> Ok, closing the index solved the problem. This also explains the outcome of  
> my performance tests under 0.16.\* 😉
> 
> For which other settings the index has to be closed first?
> 
> Thanks for your help.

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [July 30, 2011, 7:05pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/7 "2011-07-30T19:05:23Z")

</div>

Ok, now it makes more and more sense. Probably I should check the docu more  
frequently for changes. I will add some notes about this to Elastica.

What do you exactly mean by log settings that have not been applied? Can it  
happen that the settings are changed and they are not already applied at the  
next request? Would refresh help?

Btw: It is a little bit confusing that merge policy is also listed in the  
table but can't be changed (I know, it's on an other page). Perhaps a small  
note would help. And their is a small typo in policy in the table.

One more question: The three different merge policy types, do they exist as  
templates and is it possible to change between these templates, or is just a  
definition? How does a switch happen?

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [July 31, 2011, 9:52am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/8 "2011-07-31T09:52:59Z")

</div>

On Sat, Jul 30, 2011 at 10:05 PM, ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> Ok, now it makes more and more sense. Probably I should check the docu more  
> frequently for changes. I will add some notes about this to Elastica.
> 
> What do you exactly mean by log settings that have not been applied? Can it  
> happen that the settings are changed and they are not already applied at the  
> next request? Would refresh help?

I mean settings that are not supported in being changed on an open index.

> Btw: It is a little bit confusing that merge policy is also listed in the  
> table but can't be changed (I know, it's on an other page). Perhaps a small  
> note would help. And their is a small typo in policy in the table.

Yea, you are right. I added a better description.

> One more question: The three different merge policy types, do they exist as  
> templates and is it possible to change between these templates, or is just a  
> definition? How does a switch happen?

Not sure I understand the question...

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [July 31, 2011, 10:36pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/9 "2011-07-31T22:36:12Z")

</div>

Ok, I try the last question again 😉

Here you have listed three different types of merge policies (tiered,  
log\_by\_size, log\_doc):  
[http://www.elasticsearch.org/guide/reference/index-modules/merge.html](http://www.elasticsearch.org/guide/reference/index-modules/merge.html)

Are these predefined merge policy templates and is it somehow possible to  
switch between these templates through the API? Or is it necessary to change  
all the settings one by one to get to the other merge policy type?

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [August 1, 2011, 6:27am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/10 "2011-08-01T06:27:21Z")

</div>

The default merge policy in 0.17 is the tiered one (a new merge policy  
introduced in Lucene 3.3, which 0.17 comes with). If you want to change the  
merge policy type, you need to change it on a closed index, by setting the  
relevant setting for it, for example, set index.merge.policy.type to  
`log_by_size`. On an open index, you can change all the settings associated  
with the current merge policy used.

On Mon, Aug 1, 2011 at 1:36 AM, ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> Ok, I try the last question again 😉
> 
> Here you have listed three different types of merge policies (tiered,  
> log\_by\_size, log\_doc):  
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/guide/reference/index-modules/merge.html)
> 
> Are these predefined merge policy templates and is it somehow possible to  
> switch between these templates through the API? Or is it necessary to change  
> all the settings one by one to get to the other merge policy type?

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [August 1, 2011, 10:33am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/11 "2011-08-01T10:33:58Z")

</div>

This is getting more and more interesting. This means, I can change  
merge\_policy on an open index, if the policy type is log\_bytes\_size?

I tried to change the policy type to log\_bytes\_size but this lead to an  
endless loop in elasticsearch (even though it was returned successfully). I  
figured out the following:  
In the documentation it is named log\_bytes\_size. But the java class name is  
LogByteSize (singular). I also tried to set the policy value with  
lob\_byte\_size or LogByteSize, both didn't work.

Elasticsearch throws out (in an endless loop) the following message, until  
the index is deleted:

[2011-08-01 12:28:09,044][WARN][cluster.action.shard] [Husk] sending  
failed shard for [test][2], node[MxR7mlleRNaTbruLG2A\_-w], [P],  
s[INITIALIZING], reason [Failed to create shard, message  
[CreationException[Guice creation errors:

1. An exception was caught and reported. Message: Failed to load class  
setting [index.merge.policy.type] with value [LogByteSize]  
at  
org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:142)

2. No implementation for  
org.elasticsearch.index.merge.policy.MergePolicyProvider was bound.  
at  
org.elasticsearch.index.merge.policy.MergePolicyModule.configure(MergePolicyModule.java:37)

2 errors]; nested: NoClassSettingsException[Failed to load class setting  
[index.merge.policy.type] with value [LogByteSize]]; nested:  
ClassNotFoundException[LogByteSize]; ]]  
[2011-08-01 12:28:09,044][WARN][cluster.action.shard] [Husk] received  
shard failed for [test][2], node[MxR7mlleRNaTbruLG2A\_-w], [P],  
s[INITIALIZING], reason [Failed to create shard, message  
[CreationException[Guice creation errors:

1. An exception was caught and reported. Message: Failed to load class  
setting [index.merge.policy.type] with value [LogByteSize]  
at  
org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:142)

2. No implementation for  
org.elasticsearch.index.merge.policy.MergePolicyProvider was bound.  
at  
org.elasticsearch.index.merge.policy.MergePolicyModule.configure(MergePolicyModule.java:37)

2 errors]; nested: NoClassSettingsException[Failed to load class setting  
[index.merge.policy.type] with value [LogByteSize]]; nested:  
ClassNotFoundException[LogByteSize]; ]]  
Aug 1, 2011 12:28:09 PM org.elasticsearch.common.inject.MessageProcessor  
visit  
INFO: An exception was caught and reported. Message:  
java.lang.ClassNotFoundException: LogByteSize  
org.elasticsearch.common.settings.NoClassSettingsException: Failed to load  
class setting [index.merge.policy.type] with value [LogByteSize]  
at  
org.elasticsearch.common.settings.ImmutableSettings.getAsClass(ImmutableSettings.java:224)  
at  
org.elasticsearch.index.merge.policy.MergePolicyModule.configure(MergePolicyModule.java:37)  
at  
org.elasticsearch.common.inject.AbstractModule.configure(AbstractModule.java:59)  
at  
org.elasticsearch.common.inject.spi.Elements$RecordingBinder.install(Elements.java:210)  
at  
org.elasticsearch.common.inject.spi.Elements.getElements(Elements.java:91)  
at  
org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:142)  
at  
org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:103)  
at  
org.elasticsearch.common.inject.InjectorImpl.createChildInjector(InjectorImpl.java:138)  
at  
org.elasticsearch.common.inject.ModulesBuilder.createChildInjector(ModulesBuilder.java:65)  
at  
org.elasticsearch.index.service.InternalIndexService.createShard(InternalIndexService.java:288)  
at  
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:526)  
at  
org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:495)  
at  
org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:178)  
at  
org.elasticsearch.cluster.service.InternalClusterService$2.run(InternalClusterService.java:254)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
at  
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
at java.lang.Thread.run(Thread.java:680)  
Caused by: java.lang.ClassNotFoundException: LogByteSize  
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)  
at java.security.AccessController.doPrivileged(Native Method)  
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)  
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)  
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)  
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)  
at  
org.elasticsearch.common.settings.ImmutableSettings.getAsClass(ImmutableSettings.java:214)  
... 16 more

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [August 1, 2011, 8:13pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/12 "2011-08-01T20:13:53Z")

</div>

First, there is a bug in the docs regarding the setting name, it should be  
log\_byte\_size. I fixed it, but there is still a bug when setting it using  
the mentioned descriptive value, opened an issue nad pushed a fix:  
[Merge Policy type setting fails · Issue #1190 · elastic/elasticsearch · GitHub](https://github.com/elasticsearch/elasticsearch/issues/1190).

Regarding changing settings. On an open index, you can only change the  
settings of a specific type chosen. You can't change the type itself. If the  
current merge policy of hte index is tiered, you can change tiered level  
settings, and they will be applied, if its log\_byte\_size, then you can  
change log\_byte\_size relevant settings and they will be applied.

On Mon, Aug 1, 2011 at 1:33 PM, ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> This is getting more and more interesting. This means, I can change  
> merge\_policy on an open index, if the policy type is log\_bytes\_size?
> 
> I tried to change the policy type to log\_bytes\_size but this lead to an  
> endless loop in elasticsearch (even though it was returned successfully). I  
> figured out the following:  
> In the documentation it is named log\_bytes\_size. But the java class name is  
> LogByteSize (singular). I also tried to set the policy value with  
> lob\_byte\_size or LogByteSize, both didn't work.
> 
> Elasticsearch throws out (in an endless loop) the following message, until  
> the index is deleted:
> 
> [2011-08-01 12:28:09,044][WARN][cluster.action.shard] [Husk] sending  
> failed shard for [test][2], node[MxR7mlleRNaTbruLG2A\_-w], [P],  
> s[INITIALIZING], reason [Failed to create shard, message  
> [CreationException[Guice creation errors:
> 
> 1. An exception was caught and reported. Message: Failed to load class  
> setting [index.merge.policy.type] with value [LogByteSize]  
> at  
> org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:142)
> 
> 2. No implementation for  
> org.elasticsearch.index.merge.policy.MergePolicyProvider was bound.  
> at  
> org.elasticsearch.index.merge.policy.MergePolicyModule.configure(MergePolicyModule.java:37)
> 
> 2 errors]; nested: NoClassSettingsException[Failed to load class setting  
> [index.merge.policy.type] with value [LogByteSize]]; nested:  
> ClassNotFoundException[LogByteSize]; ]]  
> [2011-08-01 12:28:09,044][WARN][cluster.action.shard] [Husk] received  
> shard failed for [test][2], node[MxR7mlleRNaTbruLG2A\_-w], [P],  
> s[INITIALIZING], reason [Failed to create shard, message  
> [CreationException[Guice creation errors:
> 
> 1. An exception was caught and reported. Message: Failed to load class  
> setting [index.merge.policy.type] with value [LogByteSize]  
> at  
> org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:142)
> 
> 2. No implementation for  
> org.elasticsearch.index.merge.policy.MergePolicyProvider was bound.  
> at  
> org.elasticsearch.index.merge.policy.MergePolicyModule.configure(MergePolicyModule.java:37)
> 
> 2 errors]; nested: NoClassSettingsException[Failed to load class setting  
> [index.merge.policy.type] with value [LogByteSize]]; nested:  
> ClassNotFoundException[LogByteSize]; ]]  
> Aug 1, 2011 12:28:09 PM org.elasticsearch.common.inject.MessageProcessor  
> visit  
> INFO: An exception was caught and reported. Message:  
> java.lang.ClassNotFoundException: LogByteSize  
> org.elasticsearch.common.settings.NoClassSettingsException: Failed to load  
> class setting [index.merge.policy.type] with value [LogByteSize]  
> at  
> org.elasticsearch.common.settings.ImmutableSettings.getAsClass(ImmutableSettings.java:224)  
> at  
> org.elasticsearch.index.merge.policy.MergePolicyModule.configure(MergePolicyModule.java:37)  
> at  
> org.elasticsearch.common.inject.AbstractModule.configure(AbstractModule.java:59)  
> at  
> org.elasticsearch.common.inject.spi.Elements$RecordingBinder.install(Elements.java:210)  
> at  
> org.elasticsearch.common.inject.spi.Elements.getElements(Elements.java:91)  
> at  
> org.elasticsearch.common.inject.InjectorShell$Builder.build(InjectorShell.java:142)  
> at  
> org.elasticsearch.common.inject.InjectorBuilder.build(InjectorBuilder.java:103)  
> at  
> org.elasticsearch.common.inject.InjectorImpl.createChildInjector(InjectorImpl.java:138)  
> at  
> org.elasticsearch.common.inject.ModulesBuilder.createChildInjector(ModulesBuilder.java:65)  
> at  
> org.elasticsearch.index.service.InternalIndexService.createShard(InternalIndexService.java:288)  
> at  
> org.elasticsearch.indices.cluster.IndicesClusterStateService.applyInitializingShard(IndicesClusterStateService.java:526)  
> at  
> org.elasticsearch.indices.cluster.IndicesClusterStateService.applyNewOrUpdatedShards(IndicesClusterStateService.java:495)  
> at  
> org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:178)  
> at  
> org.elasticsearch.cluster.service.InternalClusterService$2.run(InternalClusterService.java:254)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)  
> at  
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: java.lang.ClassNotFoundException: LogByteSize  
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)  
> at java.security.AccessController.doPrivileged(Native Method)  
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)  
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)  
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)  
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)  
> at  
> org.elasticsearch.common.settings.ImmutableSettings.getAsClass(ImmutableSettings.java:214)  
> ... 16 more

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [August 1, 2011, 8:18pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/13 "2011-08-01T20:18:01Z")

</div>

Thx for the fast fix. I will try everything as soon as I get some time.  
Probably then already 0.17.3 is released 😉

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [August 4, 2011, 4:44pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/14 "2011-08-04T16:44:19Z")

</div>

I just tried out setting a type and everything with ES 0.17.3. Everything  
seems to work. But now I can set any setting I want (also not existing once)  
and it will return true. So I don't really know, if the type was changed or  
not. I would expect that I get an error returned, if I try to set a not  
existing setting. Or is this as expected?

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [August 15, 2011, 6:04am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/15 "2011-08-15T06:04:24Z")

</div>

I just tried it with 0.17.6 again, and I'm able to set any not existing  
settings and elasticsearch returns ok (and also stores the not existing  
setting). Can you give me some more details here what should be expected?

---

<div class="post-metadata">

### Author: ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)
#### Post date: [August 15, 2011, 10:56am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/16 "2011-08-15T10:56:57Z")

</div>

Can you gist a curl sample of what you do?

On Mon, Aug 15, 2011 at 9:04 AM, ruflin [ruflin@gmail.com](mailto:ruflin@gmail.com) wrote:

> I just tried it with 0.17.6 again, and I'm able to set any not existing  
> settings and elasticsearch returns ok (and also stores the not existing  
> setting). Can you give me some more details here what should be expected?

---

<div class="post-metadata">

### Author: ![ruflin\_2](https://avatars.discourse-cdn.com/v4/letter/r/a8b319/32.png) [@ruflin\_2](https://discuss.elastic.co/u/ruflin_2)
#### Post date: [August 15, 2011, 12:20pm UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/17 "2011-08-15T12:20:21Z")

</div>

Here it is:

> <https://gist.github.com/ruflin/1146118>

I'm suprised by the last line of the output (hello\_world settings). Also as  
I unserstood you before, it should not be possible to  
set expunge\_deletes\_allowed on an open index. But it also appears in the  
settings and returns ok.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 3:56am UTC](https://discuss.elastic.co/t/merge-policy-not-in-settings/5000/18 "2017-07-06T03:56:56Z")

</div>


