# "message":"Authentication of \[kibana\_system\] was terminated by realm \[reserved\] - failed to authenticate user \[kibana\_system\]"

**URL:** https://discuss.elastic.co/t/message-authentication-of-kibana-system-was-terminated-by-realm-reserved-failed-to-authenticate-user-kibana-system/358460
**Category:** Kibana
**Tags:** docker
**Created:** [April 30, 2024, 5:50am UTC](https://discuss.elastic.co/t/message-authentication-of-kibana-system-was-terminated-by-realm-reserved-failed-to-authenticate-user-kibana-system/358460 "2024-04-30T05:50:41Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![mohammadreza\_davarza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohammadreza_davarza/32/130350_2.png) [@mohammadreza\_davarza](https://discuss.elastic.co/u/mohammadreza_davarza)
#### Post date: [April 30, 2024, 5:50am UTC](https://discuss.elastic.co/t/message-authentication-of-kibana-system-was-terminated-by-realm-reserved-failed-to-authenticate-user-kibana-system/358460/1 "2024-04-30T05:50:41Z")

</div>

hello  
i wrote a compose file for setting up elastic and kibana but it seems that in kibana environment section ELASTICSEARCH\_PASSWORD="something" can't pass the value to elastic container.  
i checked the compose file thousand times and i think its ok  
only way i found was manually change kibana\_system password in elasticsearch container with the value of ELASTICSEARCH\_PASSWORD in my compose but i can't do this for every environment that i want to install elastic and with every restart the containers.  
my elastic host works fine with the password but kibana isn't.  
after that i used [Getting started with the Elastic Stack and Docker-Compose | Elastic Blog](https://www.elastic.co/blog/getting-started-with-the-elastic-stack-and-docker-compose) document and copy the exact lines and just changed variables but the same problem shown up again.
