# Message "failed to load host information: 1 error: no /etc/\<distrib\>-release file found"

**URL:** <https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556>\
**Category:** Beats\
**Tags:** auditbeat\
**Created:** [September 22, 2019, 2:45am UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556 "2019-09-22T02:45:41Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![michaelberg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaelberg/32/51063_2.png) [@michaelberg](https://discuss.elastic.co/u/michaelberg)\
**Post date:** [September 22, 2019, 2:45am UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/1 "2019-09-22T02:45:41Z")

</div>

Good evening!

I am getting "failed to load host information: 1 error: no /etc/-release file found" popping up all over my Auditbeat output and it's making it's way into Kibana/Elasticsearch as well ..

Running Fedora 30 server ...

I took a look /etc and see the Sym link "fedora-release" and it's points as follows:

 ![21%20PM](https://us1.discourse-cdn.com/elastic/original/3X/6/3/63e9cf373379c06757b55c369be8e2a7b333ee12.png)

Is Auditbeat having issues reading it possibly??? Would appreciate some feedback to see if someone has seen this before ...

Thanks kindly!

---

<div class="post-metadata">

**Author:** ![Michael\_Madden](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michael_madden/32/46640_2.png) [@Michael\_Madden](https://discuss.elastic.co/u/Michael_Madden)\
**Post date:** [September 23, 2019, 4:04pm UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/2 "2019-09-23T16:04:42Z")

</div>

Hello, thanks for reaching out about the auditbeat issue on Fedora 30.

I'm hitting the same issue with a simple Go program that uses some of the same libraries at auditbeat.

> <https://github.com/elastic/beats/blob/master/x-pack/auditbeat/module/system/host/host.go#L298-L317>

`panic: 1 error: no /etc/<distrib>-release file found`

I will continue to investigate this and will likely file an issue with one of our following projects:

> **[elastic/go-sysinfo](https://github.com/elastic/go-sysinfo)**
>
> go-sysinfo is a library for collecting system information. - elastic/go-sysinfo

  

> **[elastic/beats](https://github.com/elastic/beats)**
>
> :tropical\_fish: Beats - Lightweight shippers for Elasticsearch & Logstash - elastic/beats

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [September 23, 2019, 4:20pm UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/3 "2019-09-23T16:20:01Z")

</div>

There's an issue for this at [https://github.com/elastic/go-sysinfo/issues/57](https://github.com/elastic/go-sysinfo/issues/57). A code update is needed to go-sysinfo to make the check less restrictive an allow reading symlinks.

---

<div class="post-metadata">

**Author:** ![michaelberg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaelberg/32/51063_2.png) [@michaelberg](https://discuss.elastic.co/u/michaelberg)\
**Post date:** [September 23, 2019, 5:22pm UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/4 "2019-09-23T17:22:03Z")

</div>

Andrew ...

Please forgive my ignorance in asking .... but is this a code update that I can do on my end or this a bug that we need to wait for Elasticsearch to fix and release in a future version?

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [September 23, 2019, 7:48pm UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/5 "2019-09-23T19:48:31Z")

</div>

It's a change that needs to be made in [https://github.com/elastic/go-sysinfo](https://github.com/elastic/go-sysinfo) and then a new release of Auditbeat can be made by Elastic that will include the fix. But you are welcome to submit a pull request with a fix if you are familiar with git and Go 😄.

---

<div class="post-metadata">

**Author:** ![michaelberg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaelberg/32/51063_2.png) [@michaelberg](https://discuss.elastic.co/u/michaelberg)\
**Post date:** [September 23, 2019, 10:15pm UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/6 "2019-09-23T22:15:03Z")

</div>

Andrew ...

Thanks kindly .... I would love to do that but, sadly, I am not familiar enough with Git and Go to attempt such a change!

In the meantime I will just wait for a change and not worry about those error messages ... I'll see if there's a way I can filter them out so they don't all end up in Elasticsearch which is what is happening now!

Have a great week ...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 14, 2019, 10:15pm UTC](https://discuss.elastic.co/t/message-failed-to-load-host-information-1-error-no-etc-distrib-release-file-found/200556/7 "2019-10-14T22:15:03Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
