# :message=\>"Failed to send event to Redis"

**URL:** <https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850>\
**Category:** Logstash\
**Created:** [February 16, 2016, 8:01am UTC](https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850 "2016-02-16T08:01:37Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shrawan\_Bhagwat](https://avatars.discourse-cdn.com/v4/letter/s/a87d85/32.png) [@Shrawan\_Bhagwat](https://discuss.elastic.co/u/Shrawan_Bhagwat)\
**Post date:** [February 16, 2016, 8:01am UTC](https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850/1 "2016-02-16T08:01:37Z")

</div>

Hi All,

We are getting this error message in logstash logs:  
{:timestamp=\>"2016-02-16T13:31:05.697000+0530", :message=\>"Failed to send event to Redis", :event=\>#\<LogStash::Event:0x19f9088 @accessors=#\<LogStash::Util::Accessors:0xc9dee3 @store={"message"=\>"dhdieiidjpie", "@version"=\>"1", "@timestamp"=\>"2016-02-16T06:42:35.738Z", "type"=\>"Test\_check",

We are using logstash-1.5.3 and redis 3.0.1.

Please Guide.

Regards,  
Shrawan

---

<div class="post-metadata">

**Author:** ![Python\_Coder](https://avatars.discourse-cdn.com/v4/letter/p/aeb1de/32.png) [@Python\_Coder](https://discuss.elastic.co/u/Python_Coder)\
**Post date:** [March 3, 2016, 11:34am UTC](https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850/2 "2016-03-03T11:34:53Z")

</div>

I just solved the same issue in my server, in my case the problem was in the bind ip address of redis, i have been binding to an ip address of 172.16.122.120 which is a Virtual ip shared between 2 redis server, and after i changed the binding ip to the 172.16.122.201 on redis 1 and 172.16.122.202 on redis 2 and make changes to the host option on logstash shipper, it remained sending data to redis on 172.16.122.120. and the same exception has raised `(:message=>"Failed to send event to Redis")`  
i just fixed the issue by changing the following directive on logstash shipper 🙂

> host =\> ["172.16.122.120", "172.16.122.201", "172.16.122.202"]  
> shuffle\_hosts =\> true

Otherwise, i think it's a cache issue, try to find how to clear it.

Note:  
the above config has been put in place to figure out the issue only.

---

<div class="post-metadata">

**Author:** ![Shrawan\_Bhagwat](https://avatars.discourse-cdn.com/v4/letter/s/a87d85/32.png) [@Shrawan\_Bhagwat](https://discuss.elastic.co/u/Shrawan_Bhagwat)\
**Post date:** [March 4, 2016, 5:22pm UTC](https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850/3 "2016-03-04T17:22:23Z")

</div>

Hi Coder,

Thanks for the Suggestion 🙂

We have tried that but it didn't work. 😔

We have upgraded to logstash-1.5.3 🙂

Regards,  
Shrawan

---

<div class="post-metadata">

**Author:** ![Python\_Coder](https://avatars.discourse-cdn.com/v4/letter/p/aeb1de/32.png) [@Python\_Coder](https://discuss.elastic.co/u/Python_Coder)\
**Post date:** [March 4, 2016, 5:23pm UTC](https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850/4 "2016-03-04T17:23:21Z")

</div>

i'm happy to hear that 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:08am UTC](https://discuss.elastic.co/t/message-failed-to-send-event-to-redis/41850/5 "2017-07-06T05:08:19Z")

</div>


