# Message field failed to store more than 500 lines

**URL:** https://discuss.elastic.co/t/message-field-failed-to-store-more-than-500-lines/84660
**Category:** Logstash
**Created:** [May 5, 2017, 6:23am UTC](https://discuss.elastic.co/t/message-field-failed-to-store-more-than-500-lines/84660 "2017-05-05T06:23:46Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)
#### Post date: [May 5, 2017, 6:23am UTC](https://discuss.elastic.co/t/message-field-failed-to-store-more-than-500-lines/84660/1 "2017-05-05T06:23:46Z")

</div>

HI,  
In my log one event contain more than 2000 line(XML) when i process the log, i could see first 500 line of the event in kibana.

I am using file input plugin and wanted to know if Logstash has a size limit for each message/event?  
If yes, is it configurable? I am not able to find it in any documentation.

Appreciate if anyone help me on this.

---

<div class="post-metadata">

### Author: ![guyboertje](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/guyboertje/32/31592_2.png) [@guyboertje](https://discuss.elastic.co/u/guyboertje)
#### Post date: [May 12, 2017, 9:38am UTC](https://discuss.elastic.co/t/message-field-failed-to-store-more-than-500-lines/84660/2 "2017-05-12T09:38:26Z")

</div>

You are probably using the multiline codec. If so check out this config option [https://www.elastic.co/guide/en/logstash/current/plugins-codecs-multiline.html#plugins-codecs-multiline-max\_lines](https://www.elastic.co/guide/en/logstash/current/plugins-codecs-multiline.html#plugins-codecs-multiline-max_lines)

---

<div class="post-metadata">

### Author: ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)
#### Post date: [May 17, 2017, 11:51am UTC](https://discuss.elastic.co/t/message-field-failed-to-store-more-than-500-lines/84660/3 "2017-05-17T11:51:44Z")

</div>

thank you @guyboertje. Problem resolved

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 14, 2017, 11:52am UTC](https://discuss.elastic.co/t/message-field-failed-to-store-more-than-500-lines/84660/4 "2017-06-14T11:52:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
