# Metric beat does not install any module (error: line 101)

**URL:** <https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951>\
**Category:** Metrics\
**Created:** [August 31, 2021, 5:43pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951 "2021-08-31T17:43:17Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![potap75](https://avatars.discourse-cdn.com/v4/letter/p/aeb1de/32.png) [@potap75](https://discuss.elastic.co/u/potap75)\
**Post date:** [August 31, 2021, 5:43pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/1 "2021-08-31T17:43:17Z")

</div>

Prod ELK v 7.11. monitoring cluster 7.11  
Installed Metricbeat 7.13 on Logstash node to collect metrics. Have been following the steps in this guide: [https://www.elastic.co/guide/en/logstash/7.11/monitoring-with-metricbeat.html](https://www.elastic.co/guide/en/logstash/7.11/monitoring-with-metricbeat.html).  
when I got to the point of "enable logstash-xpack" I got this error:

```auto
$ sudo metricbeat modules enable logstash-xpack
**Error initializing beat: error loading config file: yaml: line 101: did not find expected key**.

```

then I tried enabling ANY module in modules.d and got the same error.  
Please help.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [August 31, 2021, 7:28pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/2 "2021-08-31T19:28:51Z")

</div>

Hi @potap75 Welcome to the community...

That Looks like perhaps a syntax error in your filebeat.yml...

Perhaps you could share it

If you do please format the text with the formatter button `</>`

it is also not recommended to run beats that are versions ahead of the rest of the stack. See [here](https://www.elastic.co/guide/en/elastic-stack/current/upgrading-elastic-stack.html)

---

<div class="post-metadata">

**Author:** ![potap75](https://avatars.discourse-cdn.com/v4/letter/p/aeb1de/32.png) [@potap75](https://discuss.elastic.co/u/potap75)\
**Post date:** [August 31, 2021, 8:49pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/3 "2021-08-31T20:49:28Z")

</div>

Metricbeat config:

```auto
###################### Metricbeat Configuration Example #######################

# This file is an example configuration file highlighting only the most common
# options. The metricbeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/metricbeat/index.html

# =========================== Modules configuration ============================

metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

# ======================= Elasticsearch template setting =======================

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

# ================================= Dashboards =================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
#setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "http://XX.XX.X.X:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  #space.id:
 # =============================== Elastic Cloud ================================

# These settings simplify using Metricbeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
output.elasticsearch:
  # Array of hosts to connect to.
          hosts: ["XX.XX.X.X:9200", "XX.XX.X.X:9200"]

  # Protocol - either `http` (default) or `https`.
  #protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: "id:api_key"
   username: "remote_monitoring_user"
   password: "XXXXXXXXXXXXXX"

# ------------------------------ Logstash Output -------------------------------
#output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================

# Configure processors to enhance or manipulate events generated by the beat.

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

# ================================== Logging ===================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publisher", "service".
#logging.selectors: ["*"]

# ============================= X-Pack Monitoring ==============================
# Metricbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: true

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Metricbeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.
#monitoring.cluster_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.
#monitoring.elasticsearch:

# ============================== Instrumentation ===============================

# Instrumentation support for the metricbeat.
#instrumentation:
    # Set to true to enable instrumentation of metricbeat.
    #enabled: false

    # Environment in which metricbeat is running on (eg: staging, production, etc.)
    #environment: ""

    # APM Server hosts to report instrumentation results to.
    #hosts:
    # - http://localhost:8200

    # API Key for the APM Server(s).
    # If api_key is set then secret_token will be ignored.
    #api_key:

    # Secret token for the APM Server(s).
    #secret_token:

# ================================= Migration ==================================
# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true
                                           

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [August 31, 2021, 9:39pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/4 "2021-08-31T21:39:56Z")

</div>

> [@potap75](#):
>
> ```auto
> output.elasticsearch:
> # Array of hosts to connect to.
> hosts: ["XX.XX.X.X:9200", "XX.XX.X.X:9200"]m <!----- Wrong Indentation with username and password below
> 
> ```

That looks wrongly formatted / indented... yaml is very picky  
Should be same indentation as

> [@potap75](#):
>
> ```auto
> username: "remote_monitoring_user"
> password: "XXXXXXXXXXXXXX"
> 
> ```

---

<div class="post-metadata">

**Author:** ![potap75](https://avatars.discourse-cdn.com/v4/letter/p/aeb1de/32.png) [@potap75](https://discuss.elastic.co/u/potap75)\
**Post date:** [August 31, 2021, 9:44pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/5 "2021-08-31T21:44:18Z")

</div>

Oh, wow! Thank you so much! That solved the problem. Who would've thought...

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [August 31, 2021, 10:27pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/6 "2021-08-31T22:27:26Z")

</div>

You need to be very careful with yaml formatting... there error kinda told you ... 🙂

```auto
**Error initializing beat: error loading config file: yaml: line 101: did not find expected key**.

```

Good Luck!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 28, 2021, 10:28pm UTC](https://discuss.elastic.co/t/metric-beat-does-not-install-any-module-error-line-101/282951/7 "2021-09-28T22:28:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
