# Metric beat ssl configuration is not working in linux6

**URL:** https://discuss.elastic.co/t/metric-beat-ssl-configuration-is-not-working-in-linux6/245247
**Category:** Beats
**Tags:** elastic-stack-security, metricbeat
**Created:** [August 17, 2020, 2:18pm UTC](https://discuss.elastic.co/t/metric-beat-ssl-configuration-is-not-working-in-linux6/245247 "2020-08-17T14:18:55Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![manojb1-in.ibm.com](https://avatars.discourse-cdn.com/v4/letter/m/c68b51/32.png) [@manojb1-in.ibm.com](https://discuss.elastic.co/u/manojb1-in.ibm.com)
#### Post date: [August 17, 2020, 2:18pm UTC](https://discuss.elastic.co/t/metric-beat-ssl-configuration-is-not-working-in-linux6/245247/1 "2020-08-17T14:18:55Z")

</div>

Below is metricbeat.yml file

> ```
> etricbeat.config.modules:
> path: ${path.config}/modules.d/*.yml
> reload.enabled: false
> setup.template.settings:
> index.number_of_shards: 1
> index.codec: best_compression
> setup.dashboards.enabled: true
> setup.kibana:
> host: "10.208.77.75"
> protocol: "https"
> ssl.verification_mode: none
> output.elasticsearch:
> hosts: ["10.208.77.75:9200", "10.208.77.76:9200", "10.208.77.77:9200", "10.208.77.78:9200"]
> protocol: "https"
> username: "elastic"
> password: "xxxx"
> ssl.verification_mode: none
> processors:
> - add_host_metadata: ~
> ssl.enabled: false
> 
> ```

This config is working fine with rhel7 server. But in rhel6 server I am getting below error

> 2020-08-17T09:34:54.035-0400 ERROR [publisher\_pipeline\_output] pipeline/output.go:155 Failed to connect to backoff(elasticsearch([https://10.208.77.75:9200](https://10.208.77.75:9200/))): Get [https://10.208.77.75:9200](https://10.208.77.75:9200/): x509: cannot validate certificate for 10.208.77.75 because it doesn't contain any IP SANs

Can someone help how to resolve this error in linux6?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [August 18, 2020, 1:59am UTC](https://discuss.elastic.co/t/metric-beat-ssl-configuration-is-not-working-in-linux6/245247/2 "2020-08-18T01:59:18Z")

</div>

It looks like [https://www.elastic.co/guide/en/beats/filebeat/current/ssl-client-fails.html#cannot-validate-certificate](https://www.elastic.co/guide/en/beats/filebeat/current/ssl-client-fails.html#cannot-validate-certificate) is relevant to this problem.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 15, 2020, 1:59am UTC](https://discuss.elastic.co/t/metric-beat-ssl-configuration-is-not-working-in-linux6/245247/3 "2020-09-15T01:59:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
