# Metric beat unable to start when Index changed

**URL:** <https://discuss.elastic.co/t/metric-beat-unable-to-start-when-index-changed/127161>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [April 7, 2018, 10:46am UTC](https://discuss.elastic.co/t/metric-beat-unable-to-start-when-index-changed/127161 "2018-04-07T10:46:05Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ganeshmuralidhar](https://avatars.discourse-cdn.com/v4/letter/g/a3d4f5/32.png) [@ganeshmuralidhar](https://discuss.elastic.co/u/ganeshmuralidhar)\
**Post date:** [April 7, 2018, 10:46am UTC](https://discuss.elastic.co/t/metric-beat-unable-to-start-when-index-changed/127161/1 "2018-04-07T10:46:06Z")

</div>

Hi, I am trying to start metric beat on a server with the below config for Elastic Search Output  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/2/621c1639efc285773000cd4bd631b4be2e791902.png)

And I am seeing an error while starting metric beat with below message  
"Exiting: setup.template.name and setup.template.pattern have to be set if index name is modified."

Why am I seeing this error even after I have set the template name and pattern? Am I doing the config in a wrong place?

Kindly suggest.

---

<div class="post-metadata">

**Author:** ![ganeshmuralidhar](https://avatars.discourse-cdn.com/v4/letter/g/a3d4f5/32.png) [@ganeshmuralidhar](https://discuss.elastic.co/u/ganeshmuralidhar)\
**Post date:** [April 9, 2018, 5:16am UTC](https://discuss.elastic.co/t/metric-beat-unable-to-start-when-index-changed/127161/2 "2018-04-09T05:16:51Z")

</div>

Hi - I sorted this with the below changes and i am able to change the index successfully

![image](https://us1.discourse-cdn.com/elastic/original/3X/f/3/f355cdc49fd0f34c8301a04d1ad00d84bc1a0f5a.png)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/0/20aa1e1cf50626050f50e30a842177f7813ffb05.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 7, 2018, 5:16am UTC](https://discuss.elastic.co/t/metric-beat-unable-to-start-when-index-changed/127161/3 "2018-05-07T05:16:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
