# Metricbeat 5.1.2 does not start automatically

**URL:** <https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [May 17, 2017, 7:01pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165 "2017-05-17T19:01:05Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![open\_door8](https://avatars.discourse-cdn.com/v4/letter/o/439d5e/32.png) [@open\_door8](https://discuss.elastic.co/u/open_door8)\
**Post date:** [May 17, 2017, 7:01pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/1 "2017-05-17T19:01:05Z")

</div>

Hi, Elastic team

I have Metricbeat 5.1.2 installed on Client machine (Windows 7 32-bit). It does not start automatically (other Beats - Filebeat, Winlogbeat, Packetbeat, and Heartbeat - started automatically without problem).

How to make it started automatically?

Thanks,  
Dmitry

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [May 18, 2017, 12:58am UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/2 "2017-05-18T00:58:34Z")

</div>

Could you try a newer version? We fixed something in ~5.2 to slowed the startup and it timed out.

---

<div class="post-metadata">

**Author:** ![open\_door8](https://avatars.discourse-cdn.com/v4/letter/o/439d5e/32.png) [@open\_door8](https://discuss.elastic.co/u/open_door8)\
**Post date:** [May 18, 2017, 3:11pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/3 "2017-05-18T15:11:56Z")

</div>

I’ll install it on my machine but here is a question: is it compatible with Logstash 5.12/Elasticsearch 5.1.2 installed on Server machine?

Thanks,  
Dmitry

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [May 18, 2017, 3:32pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/4 "2017-05-18T15:32:20Z")

</div>

Yeah, those versions should work fine.

---

<div class="post-metadata">

**Author:** ![open\_door8](https://avatars.discourse-cdn.com/v4/letter/o/439d5e/32.png) [@open\_door8](https://discuss.elastic.co/u/open_door8)\
**Post date:** [May 18, 2017, 4:28pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/5 "2017-05-18T16:28:46Z")

</div>

Hi, Andrew

I have Beats installed on my machine

Beat name

Version

Automatically start

Notes

Filebeat

5.1.2

Yes

Packetbeat

5.1.2

Yes

Heartbeat

5.1.2

Yes

Winlogbeat

5.1.2

No

When started manually shows Error 1053

Metricbeat

5.2.2

No

When started manually shows Error 1053

[/uploads/default/original/3X/4/7/47052db2283829afa54de4dad78f433303f1f847.jpg]

Attached you’ll find all 5 .yml files.

Please help with that problem.

Thanks,  
Dmitry

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [May 18, 2017, 4:45pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/6 "2017-05-18T16:45:14Z")

</div>

So both Winlogbeat and Metricbeat failed at startup?

Sounds like the same issue as [Metricbeat Windows fails to start on reboot - timeout](https://discuss.elastic.co/t/metricbeat-windows-fails-to-start-on-reboot-timeout/84973/8)

A workaround until we know what the cause, is to modify the service to use "Automatic Delayed Start". That's according to a report in the thread linked above.

---

<div class="post-metadata">

**Author:** ![open\_door8](https://avatars.discourse-cdn.com/v4/letter/o/439d5e/32.png) [@open\_door8](https://discuss.elastic.co/u/open_door8)\
**Post date:** [May 18, 2017, 5:58pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/7 "2017-05-18T17:58:19Z")

</div>

Workaround did not help – I changed service to “Automatic (Delayed Start)” and did restart.

[/uploads/default/original/3X/8/4/84137804dc4cfa30a6a4a6ed1204381f1ead5959.jpg]

Thanks,  
Dmitry

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 15, 2017, 5:58pm UTC](https://discuss.elastic.co/t/metricbeat-5-1-2-does-not-start-automatically/86165/8 "2017-06-15T17:58:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
