# Metricbeat 6.3.0 tries to connect on 443 instead of 9243

**URL:** <https://discuss.elastic.co/t/metricbeat-6-3-0-tries-to-connect-on-443-instead-of-9243/145919>\
**Category:** Elastic Cloud Enterprise (ECE)\
**Created:** [August 24, 2018, 1:09pm UTC](https://discuss.elastic.co/t/metricbeat-6-3-0-tries-to-connect-on-443-instead-of-9243/145919 "2018-08-24T13:09:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jmcherian](https://avatars.discourse-cdn.com/v4/letter/j/ba8739/32.png) [@jmcherian](https://discuss.elastic.co/u/jmcherian)\
**Post date:** [August 24, 2018, 1:09pm UTC](https://discuss.elastic.co/t/metricbeat-6-3-0-tries-to-connect-on-443-instead-of-9243/145919/1 "2018-08-24T13:09:37Z")

</div>

Hi  
I am trying to evaluate ECE and configured a cluster and am trying to set up a issue with metric beat to send performance information to ECE cloud.

I keep getting error showing that the connection is refused. Firewall is disabled on the ECE.

## ./metricbeat --setup -e -E 'cloud.id=ecenonprd:MTAuMjUwLjIxLj' -c /etc/metricbeat/metricbeat.yml 2018-08-24T13:44:36.964+0200 INFO instance/beat.go:492 Home path: [/usr/share/metricbeat/bin] Config path: [/usr/share/metricbeat/bin] Data path: [/usr/share/metricbeat/bin/data] Logs path: [/usr/share/metricbeat/bin/logs]

- 
- 
- 
- 

2018-08-24T13:44:41.805+0200 INFO [monitoring] log/log.go:133 Uptime: 4.887001536s  
2018-08-24T13:44:41.805+0200 INFO [monitoring] log/log.go:110 Stopping metrics logging.  
2018-08-24T13:44:41.805+0200 INFO instance/beat.go:306 metricbeat stopped.  
2018-08-24T13:44:41.805+0200 ERROR instance/beat.go:691 Exiting: Error importing Kibana dashboards: fail to create the Elasticsearch loader: Error creating Elasticsearch client: Couldn't connect to any of the configured Elasticsearch hosts. Errors: [Error connection to Elasticsearch [https://containerinfo.myip.ip.es.io:443](https://containerinfo.myip.ip.es.io:443): Get [https://containerinfo.myip.ip.es.io:443](https://containerinfo.myip.ip.es.io:443): dial tcp 10.250.21.12:443: getsockopt: connection refused]  
Exiting: Error importing Kibana dashboards: fail to create the Elasticsearch loader: Error creating Elasticsearch client: Couldn't connect to any of the configured Elasticsearch hosts. Errors: [Error connection to Elasticsearch [https://containerinfo.myip.ip.es.io:443](https://containerinfo.myip.ip.es.io:443): Get [https://containerinfo.myip.ip.es.io:443](https://containerinfo.myip.ip.es.io:443): dial tcp myip:443: getsockopt: connection refused]

As I understand it should be trying to connect on 9243 which is the port on which elasticsearch and kibana is listening

Any ideas ?

Thanks  
Cheriyan

---

<div class="post-metadata">

**Author:** ![zanbel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zanbel/32/20678_2.png) [@zanbel](https://discuss.elastic.co/u/zanbel)\
**Post date:** [August 27, 2018, 8:54am UTC](https://discuss.elastic.co/t/metricbeat-6-3-0-tries-to-connect-on-443-instead-of-9243/145919/2 "2018-08-27T08:54:17Z")

</div>

Hey @jmcherian,

This is a known issue in the integration between beats and ECE that we are working to fix.

There are two possible workarounds in the meantime:

1. If you have a LB in front of ECE proxy layer you can add a redirect rule that will re-direct the traffic to the correct port, instead of the default 443.
2. You can use the "regular" username / password authentication with the relevant ES and Kibana configurations in the beats config file instead of the cloud\_id.

Hope this helps.

---

<div class="post-metadata">

**Author:** ![jmcherian](https://avatars.discourse-cdn.com/v4/letter/j/ba8739/32.png) [@jmcherian](https://discuss.elastic.co/u/jmcherian)\
**Post date:** [August 27, 2018, 10:23am UTC](https://discuss.elastic.co/t/metricbeat-6-3-0-tries-to-connect-on-443-instead-of-9243/145919/3 "2018-08-27T10:23:16Z")

</div>

Hi  
Thanks for the reply - will use ES and Kibana configurations for now.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 10, 2018, 10:36am UTC](https://discuss.elastic.co/t/metricbeat-6-3-0-tries-to-connect-on-443-instead-of-9243/145919/4 "2018-09-10T10:36:57Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
