# Metricbeat 6.7.1 - can't import dashboards

**URL:** <https://discuss.elastic.co/t/metricbeat-6-7-1-cant-import-dashboards/178644>\
**Category:** Beats\
**Created:** [April 26, 2019, 12:29pm UTC](https://discuss.elastic.co/t/metricbeat-6-7-1-cant-import-dashboards/178644 "2019-04-26T12:29:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![AndyT](https://avatars.discourse-cdn.com/v4/letter/a/47e85d/32.png) [@AndyT](https://discuss.elastic.co/u/AndyT)\
**Post date:** [April 26, 2019, 12:29pm UTC](https://discuss.elastic.co/t/metricbeat-6-7-1-cant-import-dashboards/178644/1 "2019-04-26T12:29:57Z")

</div>

Fresh install of metricbeat on a box also running ES/Kibana, all at 6.7.1. When I run "metricbeat setup --dashboards" I get the following error;

```
> 2019-04-26T12:10:58.184Z INFO elasticsearch/client.go:164 Elasticsearch url: http://localhost:9200
> 2019-04-26T12:10:58.184Z DEBUG [elasticsearch] elasticsearch/client.go:715 ES Ping(url=http://localhost:9200)
> 2019-04-26T12:10:58.262Z DEBUG [elasticsearch] elasticsearch/client.go:738 Ping status code: 200
> 2019-04-26T12:10:58.262Z INFO elasticsearch/client.go:739 Attempting to connect to Elasticsearch version 6.7.1
> 2019-04-26T12:10:58.262Z DEBUG [elasticsearch] elasticsearch/client.go:757 GET http://localhost:9200/_xpack?human=false <nil>
> 2019-04-26T12:10:58.285Z DEBUG [dashboards] dashboards/es_loader.go:333 Initialize the Elasticsearch 6.7.1 loader
> 2019-04-26T12:10:58.285Z DEBUG [dashboards] dashboards/es_loader.go:333 Elasticsearch URL http://localhost:9200
> 2019-04-26T12:10:58.285Z INFO kibana/client.go:118 Kibana url: http://localhost:5601
> 2019-04-26T12:10:58.301Z DEBUG [dashboards] dashboards/kibana_loader.go:139 Initialize the Kibana 6.7.1 loader
> 2019-04-26T12:10:58.301Z DEBUG [dashboards] dashboards/kibana_loader.go:139 Kibana URL http://localhost:5601
> 2019-04-26T12:10:58.301Z DEBUG [dashboards] dashboards/kibana_loader.go:139 Importing directory /usr/share/metricbeat/kibana/6
> 2019-04-26T12:10:58.301Z DEBUG [dashboards] dashboards/kibana_loader.go:139 Import directory /usr/share/metricbeat/kibana/6
> 2019-04-26T12:10:58.301Z DEBUG [dashboards] dashboards/kibana_loader.go:139 Import index-pattern from /usr/share/metricbeat/kibana/6/index-pattern/metricbeat.json
> 2019-04-26T12:10:58.318Z ERROR instance/beat.go:906 Exiting: Failed to import index-pattern: Failed to load directory /usr/share/metricbeat/kibana/6/index-pattern:
> error loading /usr/share/metricbeat/kibana/6/index-pattern/metricbeat.json: parsing kibana response: invalid character '<' looking for beginning of value. Response: <script> window.location = '/' </script>

```

I'm not seeing any authentication issues in my ES logs. I'm running ReadOnlyRest plugin for authentication but the user has permissions to all actions do I don't think its that. It looks as though it appears to install the index template fine.

Checked metricbeat.json and it appears valid.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2019, 2:29pm UTC](https://discuss.elastic.co/t/metricbeat-6-7-1-cant-import-dashboards/178644/2 "2019-05-24T14:29:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
