# Metricbeat AWS module on Kubernetes error

**URL:** <https://discuss.elastic.co/t/metricbeat-aws-module-on-kubernetes-error/246685>\
**Category:** Beats\
**Tags:** beats-module, metricbeat\
**Created:** [August 27, 2020, 8:48pm UTC](https://discuss.elastic.co/t/metricbeat-aws-module-on-kubernetes-error/246685 "2020-08-27T20:48:56Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![fgjensen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fgjensen/32/62320_2.png) [@fgjensen](https://discuss.elastic.co/u/fgjensen)\
**Post date:** [August 27, 2020, 8:48pm UTC](https://discuss.elastic.co/t/metricbeat-aws-module-on-kubernetes-error/246685/1 "2020-08-27T20:48:56Z")

</div>

Hello,

We have enabled the AWS module on a metricbeat on Kubernetes. The beat starts, but fails with the error message `2020-08-27T18:50:39.511Z ERROR instance/beat.go:958 Exiting: 1 error: metricset 'aws/ec2' not found`.

Is this caused by missing AWS credentials, or is it a beat configuration error? The credentials should be in place, but I not quite sure.

---

<div class="post-metadata">

**Author:** ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)\
**Post date:** [August 29, 2020, 3:29pm UTC](https://discuss.elastic.co/t/metricbeat-aws-module-on-kubernetes-error/246685/2 "2020-08-29T15:29:41Z")

</div>

Thanks for posting your question here!

What does command `./metricbeat modules list` return? Also what does your `modules.d/aws.yml` look like if this file exists.

---

<div class="post-metadata">

**Author:** ![fgjensen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fgjensen/32/62320_2.png) [@fgjensen](https://discuss.elastic.co/u/fgjensen)\
**Post date:** [August 30, 2020, 9:04am UTC](https://discuss.elastic.co/t/metricbeat-aws-module-on-kubernetes-error/246685/3 "2020-08-30T09:04:14Z")

</div>

Hello @Kaiyan_Sheng,  
Thanks for helping on this issue. The beat is version 7.8.1. It has the system and the aws modules enabled `Enabled: aws system`. For the aws module I have tried all metricsets, a few metricsets and only the ec2 metricset. The result is the is the same. The beat stops with an error messages similar to the above. Basically, the metricsets are configured a shown in the beat documentation. The credentials are not set directly in the module configuration, since the devops claims that this is handled implicitly by the roles and privileges the metricbeat is configured with in aws. I belive the credentials or at least the role\_arn should be set configured in the module as shown in the beat documentation. What is correct?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 27, 2020, 11:04am UTC](https://discuss.elastic.co/t/metricbeat-aws-module-on-kubernetes-error/246685/4 "2020-09-27T11:04:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
